Opened 7 years ago

Closed 4 years ago

#2138 closed defect (wontfix)

When drop postgis_topology extension doesn't drop topology schema

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 2.2.0
Component: topology Version: 2.0.x
Keywords: Cc:

Description

This is only an extension issue since when people uninstall topology if they used the scripts, they'd probably just drop cascade topology.

Then again I guess it might still be stuck in the search_path which could cause other issues.

Change History (7)

comment:1 Changed 6 years ago by robe

Milestone: PostGIS 2.0.4PostGIS 2.2.0

comment:2 Changed 6 years ago by strk

Does PostgreSQL provide any hook on DROP EXTENSION ?

comment:3 Changed 6 years ago by robe

Hmm I don't think so. Closest thing I can think of is 9.3 event triggers. Then we could define a trigger on drop extension event. http://www.postgresql.org/docs/9.3/interactive/event-trigger-matrix.html That sounds kind of scary though since it would check whenever any extension is dropped and not sure what happens if you have an event trigger as part of an extension and its triggering would drop itself. We might have to push this to PostGIS Future and raise as a feature request upstream so we can do something about it.

comment:4 Changed 6 years ago by robe

I think fails our regression in #2730 as a result.

I was hoping I could get away with doing this

ALTER EXTENSION postgis_topology ADD SCHEMA topology;

but drats I get this error

ERROR:  cannot add schema "topology" to extension "postgis_topology" because the schema contains the extension

comment:5 Changed 5 years ago by strk

if the problem is just with the testcase, we could make the "cleanup" method of the script take care of dropping the topology schema explicitly (with no CASCADE, maybe)

comment:6 Changed 5 years ago by strk

Robe, see how you like r13171 (in trunk) -- not sure it'd be worth backporting, not being a core issue

comment:7 Changed 4 years ago by robe

Resolution: wontfix
Status: newclosed

good enough. I'm fine with it not working for install which was the underlying issue I complained about.

Note: See TracTickets for help on using tickets.