Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2498 closed defect (duplicate)

PostgreSQL/PostGIS hangs while creating spatial index

Reported by: wagm Owned by: pramsey
Priority: medium Milestone:
Component: postgis Version: 2.1.x
Keywords: Cc: aekorotkov@…

Description

I have a rather small table (262 rows) with POINT geometry for which I want to create a spatial index (The data I used you will find in the attached SQL file). When I try to create the spatial index on the geometry column the query will run and never end. To only way to cancel this query is to restart my computer (restarting just the PostgreSQL server won't work). If I delete just a single (arbitrary) row from this table and then run the "CREATE INDEX ..." statement the index is created within a few milliseconds. I currently have no idea what causes this behavior. I discovered the issue when I tried to restore data from a dump file and pg_restore would never finish. This happens with PostGIS 2.1 under Windows and Linux (64-Bit OS). I have not tested if this issue occurs also using PostGIS 2.0.

Many thanks, Michael

Attachments (1)

point_layer.sql (32.7 KB) - added by wagm 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by wagm

Attachment: point_layer.sql added

comment:1 Changed 6 years ago by pramsey

Cc: aekorotkov@… added

Looks like a duplicate of #2449. This will need to be patch/released sooner than later if multiple people are hitting it.

comment:2 Changed 6 years ago by pramsey

Resolution: duplicate
Status: newclosed

Excellent, not only is this a dupe of #2499, but it provides a repeatable test case of the fix, which does work.

comment:3 in reply to:  2 Changed 6 years ago by pramsey

Replying to pramsey:

Excellent, not only is this a dupe of #2499, but it provides a repeatable test case of the fix, which does work.

Er, dupe of #2449

Note: See TracTickets for help on using tickets.