Opened 11 years ago

Closed 10 years ago

#2266 closed defect (worksforme)

GEOS requirement misstated

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 2.0.4
Component: postgis Version: 2.0.x
Keywords: Cc:

Description (last modified by robe)

I think there is a mismatch between our minimum GEOS requirement documentation and actual requirement. Need to verify and may have to do with topology needing newer version than the rest of PostGIS proper.

See comment from Gabrielle:

Change History (12)

comment:1 by robe, 11 years ago

Owner: changed from pramsey to robe

comment:2 by robe, 11 years ago

Description: modified (diff)

comment:3 by strk, 11 years ago

From the configure script:

Topology requires GEOS version ≥ 3.3.2. Use —without-topology or install a newer GEOS.

comment:4 by robe, 11 years ago

Resolution: invalid
Status: newclosed

Ah okay then no problem. I was right. Though I didn't think topology tried to install if it had a lower GEOS.

I'll close out as a non-issue, but we probably should have one buildbot test against 3.2. Setting up debbie to do that now.

comment:5 by robe, 11 years ago

Resolution: invalid
Status: closedreopened

I can't get this to work on Debbie even using


I think our configure is all screwy with how it handles custom configs

comment:6 by robe, 11 years ago

I mean —without-topology

comment:7 by robe, 11 years ago

related #2268

comment:8 by robe, 10 years ago

Milestone: PostGIS 2.0.4PostGIS 2.1.1

I'll try to test on debbie later. Last I tried it failed miserably which is why I haven't gotten 3.2 regress testing going on debbie. Anyrate I think we DO have an issue. Which I might add would be solved if we dropped 3.2 support :)

comment:9 by pramsey, 10 years ago

I'm totally not seeing this. I installed a too-low geos in my system path (/usr/local) and installed a good geos in a custom path (/opt/geos) and configured with the custom location, and it worked fine.

./configure --with-libintl-prefix=/opt/local \
 --with-libiconv-prefix=/opt/local --with-jsondir=/opt/local \
 --with-gettext=/opt/local \

If I configure without the custom geos location, it fails, as it should, with the too-low geos.

comment:10 by robe, 10 years ago

Resolution: fixed
Status: reopenedclosed

alright if it works for you good enough for me.

comment:11 by robe, 10 years ago

Milestone: PostGIS 2.1.1PostGIS 2.0.4
Resolution: fixed
Status: closedreopened

comment:12 by robe, 10 years ago

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.