Opened 7 years ago

Closed 7 years ago

#2171 closed defect (invalid)

installation of postgis failed on Windows 64

Reported by: fahar Owned by: robe
Priority: medium Milestone: PostGIS 2.0.3
Component: build/upgrade/install Version: 2.0.x
Keywords: windows Cc:

Description

I am facing an issue while installed downloaded postgis build.

Steps:

  1. Install PostgreSQL 9.2 windows 64 on Windows 7 64 bit platform
  2. Open stackBuilder
  3. Download and install Postgis 32 bit on Windows 64 machine.
  4. Error occurred during installation.

Attachments (2)

create_templatepostgis_sql_error.txt (127 bytes) - added by fahar 7 years ago.
Screen Shot 2013-01-14 at 3.09.29 PM.png (118.7 KB) - added by fahar 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 in reply to:  description Changed 7 years ago by fahar

Replying to fahar:

I am facing an issue while installed downloaded postgis build.

Steps:

  1. Install PostgreSQL 9.2 windows 64 on Windows 7 64 bit platform
  2. Open stackBuilder
  3. Download and install Postgis 32 bit on Windows 64 machine.
  4. Error occurred during installation.

Builds copied from this location

http://download.osgeo.org/postgis/windows/pg92/

Changed 7 years ago by fahar

comment:2 Changed 7 years ago by robe

Component: postgisbuild/upgrade/install
Keywords: windows added
Owner: changed from pramsey to robe

Can you tell me what the query:

SELECT version();

returns.

comment:3 in reply to:  2 Changed 7 years ago by fahar

Replying to robe:

Can you tell me what the query:

SELECT version();

returns.

postgres=# select version();

version


PostgreSQL 9.2.2, compiled by Visual C++ build 1600, 64-bit

(1 row)

postgres=#

comment:4 Changed 7 years ago by robe

Okay. You are using the wrong downloader if you used the 32-bit. You need to use the 64-bit version ( http://download.osgeo.org/postgis/windows/pg92/postgis-pg92x64-setup-2.0.1-1.exe ). The 32-bit gives that error if you try to install on a 64-bit PostgreSQL.

comment:5 Changed 7 years ago by robe

Note you can also use the: http://download.osgeo.org/postgis/windows/pg92/postgis-pg92-binaries-2.0.2w64.zip by just extracting over your PostgreSQL install folder, but I haven't built an installer for that one yet (so its just a copy operation).

I'm a little behind (and was just thinking of waiting till 2.0.3 anyway before I bother with the installers)

comment:6 in reply to:  4 Changed 7 years ago by fahar

Replying to robe:

Okay. You are using the wrong downloader if you used the 32-bit. You need to use the 64-bit version ( http://download.osgeo.org/postgis/windows/pg92/postgis-pg92x64-setup-2.0.1-1.exe ). The 32-bit gives that error if you try to install on a 64-bit PostgreSQL.

Is by design?

If User want to install PostgreSQL 9.2 64bit installer and install potgis 32 bit installer, installation proceed and during installation postgis failed.

I think, It would be better if you add a pop up message, we can not install 32 bit installer on Windows 64 platform.

Changed 7 years ago by fahar

comment:7 Changed 7 years ago by robe

Resolution: invalid
Status: newclosed

If you used EDB stackbuilder you shouldn't have gotten the option to install the 32-bit because it would only give you the 64-bit to download. Why didn't you use that or did you and ran into issue? It sounds like you went thru the trouble of opening up stack builder. So I was a bit puzzled by that step that you then went to the PostGIS download site.

If stackbuilder is pointing you at the 32-bit installer when you are installing on 64-bit PostgreSQL, then that is a BIG concern to me.

As far as the pop up message for if you install 32-bit vs 64-bit unfortunately its not so easy to popup a message without throwing in a lot of logic to do SELECT version() this that and another and is more likely to cause more damage than good.

The main issue why I can't do that is that many people on 64-bit rightfully have 32-bit installations of PostgreSQL and may very well install such installation in an unconventional place. There is no easy way for the PostGIS installer to easily know that without building in a lot of select PostgreSQL version this that and another. If you get it from EDB stackbuilder, it should only offer you the 64-bit because it knows which version you have installed where.

I'm marking this ticket as invalid, but if your main issue is that EDB stackbuilder gave you a 32-bit download, then reopen since that is a BIG problem if it is true.

Note: See TracTickets for help on using tickets.