Opened 11 years ago

Closed 11 years ago

#2170 closed defect (fixed) doesn't work at least for newer autoconf

Reported by: robe Owned by: pramsey
Priority: blocker Milestone: PostGIS 1.3.7
Component: postgis Version: 1.3.X
Keywords: Cc:


I just tried to rebuild the 1.3 docs on Debbie and ran into issue that I can't build from svn.

checking whether ln -s works... no, using cp -p
./configure: line 3160: syntax error near unexpected token `"(('
./configure: line 3160: `case "(($ac_try" in'
make: *** [config.status] Error 2
checking for gcc... gcc

I thought it might be just debbie or change I just made to doc folder so I tried on my own windows 7 Msys 1.0 and got the same error and then tried tags/1.3.6 and got the same error. So I then tried the 1.3.6 tar ball on my local and that worked.

Issue I am guessing is autoconf because building from the tar ball where sh is not required the configure works fine.

It's only if you build the configure yourself and the issue even in the 1.3.6 tagged version is there. So somehow Hudson/Paul were able to build the tar balls and docs perhaps because they are running with an older autoconf is my guess.

anyrate not sure how to fix this since that is one of the areas I consider magic blackboxed.

Change History (5)

comment:1 by strk, 11 years ago

Works here with autoconf (GNU Autoconf) 2.68 What's the version giving you problems ? Also, is your ./configure being run by a bourne shell ? Can you try running it explicitly with bash ? bash ./configure …

comment:2 by robe, 11 years ago

On debbie:

/usr/bin/libtoolize (2.2.6b)
* Running /usr/bin/aclocal (1.11.1)
* Running /usr/bin/autoconf (2.67)

What bash / sh / bourne — I have no clue. You confused me for a unix person. My mingw has the same issue I'll have to double check what that is but I think it has

aclocal 1.11, autoconf 2.68, libtool 2.2.10.

Debbie doesn't have an issue with 1.4 though so we must have made a change between 1.3 and 1.4. Perhaps its bison or flex version. I noted I had to install flex on her to even get to that error point. I vaguely remembered that was I think when pramsey decided there was too much yacc differences in different platforms or something that he'd just have the yac yacked already.

comment:3 by pramsey, 11 years ago

Yeah, an autoconf 2.61 (circa 2006) produces a runnable configure and a 2.69 version (circa 2012) produces an un-runnable one. No warnings from either though.

comment:4 by pramsey, 11 years ago

Fixed at r11538 with some autoconf [bracketing]

comment:5 by pramsey, 11 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.