Opened 10 years ago

Closed 10 years ago

#1879 closed defect (fixed)

Export crashes shp2pgsql-gui

Reported by: bmmpxf Owned by: mcayland
Priority: medium Milestone: PostGIS 2.0.1
Component: loader/dumper Version: 2.0.x
Keywords: Cc:

Description

In PostGIS 2.0 on Windows, the shp2pgsql-gui tool crashes when an export of a valid table to file is performed. Three files are created before the app goes away (.shp, .shx, .dbf), but they are blank.

The table was imported using shp2pgsql-gui as well and appears to be valid.

Change History (3)

comment:1 by mcayland, 10 years ago

I'm afraid I haven't experienced any crashes since my last round of GUI bugfixes a couple of months ago. Do you have a shapefile you can share with us so that we can try and reproduce the issue?

comment:2 by robe, 10 years ago

bmmpxf are you running the 32-bit or 64-bit version. I think I did get a crash once during export a while ago but couldn't replicate it and it was on I think a pre PostGIS 2.0 release version of 2.0.

To verify what version you are running, can you click the About box and tell us the $Revision it says?

comment:3 by bmmpxf, 10 years ago

Resolution: fixed
Status: newclosed

Thanks for the responses. I'm running Windows 7 32-bit, so I must have downloaded the 32-bit version, via the standard installer. (Postgres 9.1.4) And shp2pgsql-gui is Revision 9583. Apologies, I should have sent that information over initially.

I just tried with the experimental build marked "2.0.1SVN" and the export worked fine, so I believe whatever it was has been fixed since last release. Thanks, everyone.

Note: See TracTickets for help on using tickets.