Opened 9 years ago

Closed 9 years ago

#1222 closed defect (fixed)

After the switch to SRID=0 topology tests fail

Reported by: strk Owned by: strk
Priority: medium Milestone: PostGIS 2.0.0
Component: topology Version: master
Keywords: Cc:

Description

Topology tests fail. Most are likely due to geometries with an explicit SRID=-1 being compared with geometries with an implicit SRID=0.

Considering both -1 and 0 as "unknown" would likely fix these cases. BTW, I suggest we have ST_Srid() return NULL for the unknown case.

Change History (3)

comment:1 Changed 9 years ago by strk

The problem is CreateTopology?(toponame) which uses a default srid of -1. Adding support for a "null" value in the "srid" column of topology.topology might help here. OR, accept that the "unknown" srid is officially '0' now and fix in that way.

Won't fix until we agree on where to go from here.

comment:2 Changed 9 years ago by robe

strk Reminder of your brilliance -- let the power of emptiness be your guide

SELECT ST_SRID('POINT EMPTY'::geometry);

comment:3 Changed 9 years ago by strk

Resolution: fixed
Status: newclosed

r7936 is the brilliant commit r7937 expects unknown to be reported as 0, fixing make check for the time being...

Note: See TracTickets for help on using tickets.