Opened 10 years ago

Closed 7 years ago

#463 closed enhancement (duplicate)

Nice boot screen with Language option

Reported by: wildintellect Owned by: live-demo@…
Priority: minor Milestone:
Component: OSGeoLive Keywords: boot splash
Cc: rpinho

Description

The current remastersys option has a very plain text based load screen on boot, with no language or keyboard selection. This would be a nice feature to add when we figure out the best way to do it.

Change history (8)

comment:1 Changed 10 years ago by hamish

as suggested by epifanio, the solution may be to set the boot type to grub instead of isolinux.

comment:2 Changed 10 years ago by hamish

Cc: rpinho added

rpinho wrote in #433:

I would like to ask suggestions for configuring Xbuntu to ask for Language, Country and Keyboard-Layout at first boot. So users can start VM with their preferred configuration and host computer Keyboard straight from the beginning.

Thanks, Ricardo Pinho

merging ticket #433 into this one. see also #484 which is a semi-dupe.

comment:3 Changed 10 years ago by hamish

I'd note that if you use the Applications → System → USB Startup Disk Creator method in Karmic to load the DVD onto a USB stick, the SYSLINUX bootloader is used, which is the standard Ubuntu one with the choice of 40 languages and the traditional Ubuntu grub menu. (at least this is the case on the standard Ubuntu (not xubuntu) dvd I made my sandbox live-usb with)

Hamish

comment:4 Changed 10 years ago by hamish

see also #484

comment:5 Changed 9 years ago by darkblueb

boot menu control continues to be a challenge.. checked in rc9

comment:6 Changed 9 years ago by wildintellect

I've discovered that remastersys lets you use a custom ISOLINUX simply by putting the files in /etc/remastersys/customisolinux/

I tried using the ISOLINUX files from the XUBUNTU disc which loaded but would not boot the live session. Maybe it's because it's really SYSLINUX, I'll have to do some more testing.

Another way to go is a chroot build which I had success on with 4.5alpha1 and did get it to boot.

comment:7 Changed 7 years ago by kalxas

Since we have now alternate build method that can solve this issue, I propose to open a new ticket about this new system and close this one here.

comment:8 Changed 7 years ago by kalxas

Resolution: duplicate
Status: newclosed

duplicate of #930

Note: See TracTickets for help on using tickets.