Opened 8 weeks ago

Last modified 7 weeks ago

#2343 new task

Update version for documentation generation

Reported by: cvvergara Owned by: osgeolive@…
Priority: normal Milestone:
Component: Documentation Keywords:
Cc:

Description

Use more recent versions for

  • Sphinx
  • cmake
  • and probably some more software that I don't have on my head

To be decided: which version to use.

Change history (3)

comment:1 Changed 8 weeks ago by cvvergara

Component: OSGeoLiveDocumentation

It seems that sphinxjp.themes.revealjs its not working, for newer versions of sphinx

But https://sphinx-revealjs.readthedocs.io/en/latest/ is similar to what we use so I am going to try one

Last edited 8 weeks ago by cvvergara (previous) (diff)

comment:3 Changed 7 weeks ago by kalxas

We should take into consideration the packaged versions of Sphinx and CMake for the base OS that we use (currently Ubuntu Focal):

https://packages.ubuntu.com/focal/sphinx-common https://packages.ubuntu.com/focal/cmake

We should probably bump the versions when we move to 22.04 this April...

Note: See TracTickets for help on using tickets.