Opened 18 months ago

Closed 3 months ago

Last modified 2 months ago

#2326 closed defect (wontfix)

OTB Tools in QGIS is not activated

Reported by: astrid_emde Owned by: osgeolive@…
Priority: major Milestone: OSGeoLive15.0
Component: OSGeoLive Keywords:
Cc: osgeolive@…

Description

When you try to activate the OTB toolbox in QGIS an error occurs as the path to otb is not defined

Attachments (1)

Bildschirmfoto von 2021-04-06 18-52-19.png (22.3 KB ) - added by astrid_emde 18 months ago.

Download all attachments as: .zip

Change history (12)

comment:1 by astrid_emde, 18 months ago

Summary: OTB Tools in QGIS can not get activatedOTB Tools in QGIS is not activated

comment:2 by astrid_emde, 18 months ago

I found this in the QGIS documentation

This configuration runs into

2021-04-06T20:13:12     INFO    OTB : OTB provider is activated from '/usr'.
2021-04-06T20:13:12     WARNING    OTB : Cannot find '/usr/share/otb/description/algs.txt'. OTB provider will be disabled

But when I try to find algs.txt via locate algs.txt it is not on the server

Here is the section that refers to OTB and QGIS. Screenshot is outdated. https://osgeo.github.io/OSGeoLive-doc/en/quickstart/otb_quickstart.html#otb-in-qgis

Last edited 18 months ago by astrid_emde (previous) (diff)

comment:3 by kalxas, 18 months ago

Cc: osgeolive@… added
Milestone: OSGeoLive14.0
Priority: normalmajor
Type: taskdefect

comment:4 by kalxas, 16 months ago

Milestone: OSGeoLive14.0OSGeoLive15.0

Ticket retargeted after milestone closed

comment:5 by darkblueb, 3 months ago

QGIS 3.22.7 on ol15 build 93 -- no OTB in Processing menu

comment:6 by sanak, 3 months ago

I forgot to mention, but there are the following errors in chroot-build.log in beta1.

===============================================================
Starting "install_otb.sh" ...
===============================================================
:
./install_otb.sh: 60: python: not found
./install_otb.sh: 108: Syntax error: "fi" unexpected

Probably, changing python => python3 on line:60 and commenting out fi on line:108 are necessary, but I will check those fix tonight.

Last edited 3 months ago by sanak (previous) (diff)

comment:7 by sanak, 3 months ago

Well, I created possible fix PR at here, but note that I haven't checked this changes locally... https://github.com/OSGeo/OSGeoLive/pull/338

comment:8 by Bas Couwenberg, 3 months ago

The Python bindings were removed in 7.0.0~rc1+dfsg-1~exp1.

/usr/lib/otb/python is no longer provided by any of the binary packages, see the buildlog:

https://launchpadlibrarian.net/606205193/buildlog_ubuntu-jammy-amd64.otb_8.0.1+dfsg-1~jammy0_BUILDING.txt.gz

in reply to:  8 comment:9 by sanak, 3 months ago

Replying to Bas Couwenberg:

The Python bindings were removed in 7.0.0~rc1+dfsg-1~exp1.

/usr/lib/otb/python is no longer provided by any of the binary packages, see the buildlog:

https://launchpadlibrarian.net/606205193/buildlog_ubuntu-jammy-amd64.otb_8.0.1+dfsg-1~jammy0_BUILDING.txt.gz

Okay, thanks for the information!

Then I close my PR...

comment:10 by kalxas, 3 months ago

Resolution: wontfix
Status: newclosed

in reply to:  2 comment:11 by sanak, 2 months ago

Replying to astrid_emde, @kalxas:

: Here is the section that refers to OTB and QGIS. Screenshot is outdated. https://osgeo.github.io/OSGeoLive-doc/en/quickstart/otb_quickstart.html#otb-in-qgis

I think that OTB Quickstart doc update will be still necessary.

Note: See TracTickets for help on using tickets.