Opened 6 months ago

Closed 3 months ago

#2134 closed enhancement (duplicate)

R version 0.7 demo

Reported by: darkblueb Owned by: osgeolive@…
Priority: major Milestone: OSGeoLive13.0
Component: OSGeoLive Keywords: R, sf
Cc:

Description

OSGeoLive 13 alpha1 includes R 3.4.4 and sf 0.7-3

Running the sample Jupyter notebook does work, but there is a missing R module called geojsonio

Edzer Pebesma says :

I have no clue where that comes from!

The fix I'd try first would be

install.packages("geojsonio")

but that might call for some external deps, like V8.

Attachments (2)

R_sf_sample_v13alpha1.pdf (478.5 KB) - added by darkblueb 6 months ago.
RJ-2018-009.pdf (281.3 KB) - added by darkblueb 6 months ago.
sf overview by edzer

Download all attachments as: .zip

Change history (6)

comment:1 Changed 6 months ago by wildintellect

Can you link the source for the notebook you are trying? It does seems weird to use geojsonio, I would assume sf would use rgdal json drivers, and we can probably trace the use and swap out a line.

Changed 6 months ago by darkblueb

Attachment: R_sf_sample_v13alpha1.pdf added

Changed 6 months ago by darkblueb

Attachment: RJ-2018-009.pdf added

sf overview by edzer

comment:2 Changed 6 months ago by wildintellect

The cause is the IRKernel specifies that geojsonio package is used to display various things from sf objects. This is specific to Jupyter. Easiest solution is to add the geojsonio R library and it's dependencies. Not sure how much space this will take. This does include need to add the system V8 library.

sudo apt-get install libv8-dev

https://github.com/IRkernel/repr/search?q=geojsonio&unscoped_q=geojsonio

comment:3 Changed 5 months ago by darkblueb

tested in nightly-build51, IRkernel 1.0 via CRAN

the same errors occur; display functions of ggplot2 work as expected

comment:4 Changed 3 months ago by darkblueb

Resolution: duplicate
Status: newclosed

see #2145 for current thread

Note: See TracTickets for help on using tickets.