#2111 closed defect (duplicate)

QGis 2.18 Plugins Broken

Reported by: darkblueb Owned by: osgeolive@…
Priority: normal Milestone: OSGeoLive12.0
Component: OSGeoLive Keywords: qgis
Cc:

Description

Launch QGis 2.18

Choose Plugins -> manage plugins -> Installed

several plugins are shown in RED as broken, for example qgis2web

Couldn't load plugin qgis2web due to an error when calling its classFactory() method 

ImportError: No module named QtWebKit 
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 333, in startPlugin
    plugins[packageName] = package.classFactory(iface)
  File "/usr/share/qgis/python/plugins/qgis2web/__init__.py", line 28, in classFactory
    from .qgis2web import Qgis2Web
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 607, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/usr/share/qgis/python/plugins/qgis2web/qgis2web.py", line 25, in 
    from maindialog import MainDialog
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 607, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/usr/share/qgis/python/plugins/qgis2web/maindialog.py", line 30, in 
    from PyQt4.QtWebKit import *
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 607, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
ImportError: No module named QtWebKit


Python version: 2.7.15rc1 (default, Apr 15 2018, 21:51:34) [GCC 7.3.0] 
QGIS version: 2.18.17 Las Palmas, exported 

Python Path:
/usr/share/qgis/python/plugins/processinglwgeomprovider
/usr/share/qgis/python/plugins/processing
/usr/share/qgis/python
/home/user/.qgis2/python
/home/user/.qgis2/python/plugins
/usr/share/qgis/python/plugins
/usr/lib/python2.7
/usr/lib/python2.7/plat-x86_64-linux-gnu
/usr/lib/python2.7/lib-tk
/usr/lib/python2.7/lib-old
/usr/lib/python2.7/lib-dynload
/usr/local/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages/gtk-2.0
/usr/lib/python2.7/dist-packages/wx-3.0-gtk3
/home/user/.qgis2//python

Change history (1)

comment:1 Changed 15 months ago by kalxas

Resolution: duplicate
Status: newclosed

duplicate of #2069

Note: See TracTickets for help on using tickets.