Opened 5 years ago

Closed 5 years ago

#1472 closed defect (fixed)

pycsw tester application not working as required for quickstart

Reported by: kalxas Owned by: kalxas
Priority: major Milestone: OSGeoLive8.5
Component: OSGeoLive Keywords:
Cc: live-demo@…, johan.vandewauw@…

Description

Today every deb file included in nightly ppa was copied and rebuilt in the release-8.5 ppa. After this process was completed, the nightly build was pointed to this new stable ppa in order to test if everything is working fine, and guess what: it does not :)

pycsw 1.8.2 (the version present in 8.0 release) was initially present in our nightly ppa providing the following packages: python-pycsw and pycsw-cgi.

Then we uploaded a package for pycsw 1.10.0 (and 1.10.1). This new package provides: python-pycsw and python-pycsw-wsgi BUT NOT pycsw-cgi.

The pycsw installer depends on pycsw-cgi to install the pycsw demo and since this package existed in the nightly ppa from 1.8.2 we did not realize (until now) that the old deb package was pulled in the build.

Now that we used the release ppa, the cgi package was not there, leaving us with a broken pycsw demo...

Change history (6)

comment:1 Changed 5 years ago by kalxas

the nightly build where this problem was detected: osgeo-live-nightly-build12328-i386.iso

comment:2 Changed 5 years ago by kalxas

The tester application is still available through python-pycsw-wsgi package. The desktop icon was missing and is now added. New deb package uploaded in nightly ppa.

comment:3 Changed 5 years ago by kalxas

Priority: criticalmajor

Fixed in [12330] Waiting to confirm in next nightly build

comment:4 Changed 5 years ago by kalxas

Owner: changed from live-demo@… to kalxas
Summary: new pycsw deb package does not provide cgi demopycsw tester application not working as required for quickstart

Desktop launcher is now confirmed fixed.

Tester application does not work though, since jquery (/usr/share/javascript/jquery) is not accessible through apache.

comment:5 Changed 5 years ago by kalxas

Fix committed in [12332]

comment:6 Changed 5 years ago by kalxas

Resolution: fixed
Status: newclosed

confirmed fixed in nightly build 12333

Note: See TracTickets for help on using tickets.