Opened 5 years ago

Closed 5 years ago

#1457 closed defect (fixed)

Sahana demo asks user to edit 000_config.py

Reported by: kalxas Owned by: live-demo@…
Priority: critical Milestone: OSGeoLive8.5
Component: OSGeoLive Keywords: 8.5alpha4
Cc: live-demo@…

Description

Since Sahana builds from SVN trunk and not from stable release, this is obviously a trunk breakage.

Change history (3)

comment:1 Changed 5 years ago by kalxas

cp: cannot stat '/usr/local/lib/web2py/applications/eden/private/templates/000_config.py': No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/models/000_config.py: No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/models/000_config.py: No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/models/000_config.py: No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/models/000_config.py: No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/private/templates/default/gis_config.csv: No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/private/templates/default/gis_config.csv: No such file or directory

comment:2 Changed 5 years ago by kalxas

Full build log:

===============================================================
Starting "install_sahana.sh" ...
===============================================================
Ign http://security.ubuntu.com trusty-security InRelease
Get:1 http://security.ubuntu.com trusty-security Release.gpg [933 B]
Ign http://ppa.launchpad.net trusty InRelease
Get:2 http://security.ubuntu.com trusty-security Release [62.0 kB]
Hit http://ppa.launchpad.net trusty Release.gpg
Ign http://archive.ubuntu.com trusty InRelease
Hit http://ppa.launchpad.net trusty Release
Hit http://ppa.launchpad.net trusty/main i386 Packages
Ign http://archive.ubuntu.com trusty-updates InRelease
Hit http://ppa.launchpad.net trusty/main Translation-en
Get:3 http://security.ubuntu.com trusty-security/main i386 Packages [184 kB]
Hit http://archive.ubuntu.com trusty Release.gpg
Hit http://archive.ubuntu.com trusty-updates Release.gpg
Get:4 http://security.ubuntu.com trusty-security/restricted i386 Packages [8846 B]
Hit http://archive.ubuntu.com trusty Release
Get:5 http://security.ubuntu.com trusty-security/universe i386 Packages [84.0 kB]
Hit http://archive.ubuntu.com trusty-updates Release
Get:6 http://security.ubuntu.com trusty-security/multiverse i386 Packages [1412 B]
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en
Hit http://archive.ubuntu.com trusty/main i386 Packages
Hit http://security.ubuntu.com trusty-security/restricted Translation-en
Hit http://archive.ubuntu.com trusty/restricted i386 Packages
Get:7 http://security.ubuntu.com trusty-security/main Translation-en [97.7 kB]
Hit http://archive.ubuntu.com trusty/universe i386 Packages
Get:8 http://security.ubuntu.com trusty-security/universe Translation-en [46.1 kB]
Hit http://archive.ubuntu.com trusty/multiverse i386 Packages
Hit http://archive.ubuntu.com trusty/main Translation-en
Hit http://archive.ubuntu.com trusty/multiverse Translation-en
Hit http://archive.ubuntu.com trusty/restricted Translation-en
Hit http://archive.ubuntu.com trusty/universe Translation-en
Hit http://archive.ubuntu.com trusty-updates/main i386 Packages
Hit http://archive.ubuntu.com trusty-updates/restricted i386 Packages
Hit http://archive.ubuntu.com trusty-updates/universe i386 Packages
Hit http://archive.ubuntu.com trusty-updates/multiverse i386 Packages
Hit http://archive.ubuntu.com trusty-updates/main Translation-en
Hit http://archive.ubuntu.com trusty-updates/multiverse Translation-en
Hit http://archive.ubuntu.com trusty-updates/restricted Translation-en
Hit http://archive.ubuntu.com trusty-updates/universe Translation-en
Fetched 485 kB in 6s (73.8 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
python-dateutil is already the newest version.
python-dateutil set to manually installed.
python-dev is already the newest version.
python-dev set to manually installed.
python-psycopg2 is already the newest version.
python-psycopg2 set to manually installed.
unzip is already the newest version.
libgeos-c1 is already the newest version.
libgeos-c1 set to manually installed.
python-shapely is already the newest version.
git is already the newest version.
python-numpy is already the newest version.
python-numpy set to manually installed.
The following extra packages will be installed:
  libwebpmux1 python-antlr python-pil python-reportlab-accel
Suggested packages:
  python-lxml-dbg python-pil-doc python-pil-dbg python-egenix-mxtexttools
  python-reportlab-doc
Recommended packages:
  python-renderpm
The following NEW packages will be installed:
  libapache2-mod-wsgi libwebpmux1 python-antlr python-imaging python-lxml
  python-pil python-reportlab python-reportlab-accel python-xlrd python-xlwt
  zlib1g-dev
0 upgraded, 11 newly installed, 0 to remove and 10 not upgraded.
Need to get 1842 kB of archives.
After this operation, 7973 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty/main libwebpmux1 i386 0.4.0-4 [13.6 kB]
Get:2 http://security.ubuntu.com/ubuntu/ trusty-security/main libapache2-mod-wsgi i386 3.4-4ubuntu2.1.14.04.2 [65.6 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ trusty/universe python-antlr all 2.7.7+dfsg-5 [20.0 kB]
Get:4 http://archive.ubuntu.com/ubuntu/ trusty/main python-pil i386 2.3.0-1ubuntu3 [277 kB]
Get:5 http://security.ubuntu.com/ubuntu/ trusty-security/main python-lxml i386 3.3.3-1ubuntu0.1 [583 kB]
Get:6 http://archive.ubuntu.com/ubuntu/ trusty/main python-imaging all 2.3.0-1ubuntu3 [4348 B]
Get:7 http://archive.ubuntu.com/ubuntu/ trusty/main python-reportlab-accel i386 3.0-1build1 [21.9 kB]
Get:8 http://archive.ubuntu.com/ubuntu/ trusty/main python-reportlab all 3.0-1build1 [449 kB]
Get:9 http://archive.ubuntu.com/ubuntu/ trusty/universe python-xlrd all 0.9.2-1 [143 kB]
Get:10 http://archive.ubuntu.com/ubuntu/ trusty/universe python-xlwt all 0.7.5+debian1-1 [83.5 kB]
Get:11 http://archive.ubuntu.com/ubuntu/ trusty/main zlib1g-dev i386 1:1.2.8.dfsg-1ubuntu1 [181 kB]
Fetched 1842 kB in 2s (882 kB/s)
Selecting previously unselected package libwebpmux1:i386.
(Reading database ... 150690 files and directories currently installed.)
Preparing to unpack .../libwebpmux1_0.4.0-4_i386.deb ...
Unpacking libwebpmux1:i386 (0.4.0-4) ...
Selecting previously unselected package libapache2-mod-wsgi.
Preparing to unpack .../libapache2-mod-wsgi_3.4-4ubuntu2.1.14.04.2_i386.deb ...
Unpacking libapache2-mod-wsgi (3.4-4ubuntu2.1.14.04.2) ...
Selecting previously unselected package python-antlr.
Preparing to unpack .../python-antlr_2.7.7+dfsg-5_all.deb ...
Unpacking python-antlr (2.7.7+dfsg-5) ...
Selecting previously unselected package python-pil.
Preparing to unpack .../python-pil_2.3.0-1ubuntu3_i386.deb ...
Unpacking python-pil (2.3.0-1ubuntu3) ...
Selecting previously unselected package python-imaging.
Preparing to unpack .../python-imaging_2.3.0-1ubuntu3_all.deb ...
Unpacking python-imaging (2.3.0-1ubuntu3) ...
Selecting previously unselected package python-lxml.
Preparing to unpack .../python-lxml_3.3.3-1ubuntu0.1_i386.deb ...
Unpacking python-lxml (3.3.3-1ubuntu0.1) ...
Selecting previously unselected package python-reportlab-accel.
Preparing to unpack .../python-reportlab-accel_3.0-1build1_i386.deb ...
Unpacking python-reportlab-accel (3.0-1build1) ...
Selecting previously unselected package python-reportlab.
Preparing to unpack .../python-reportlab_3.0-1build1_all.deb ...
Unpacking python-reportlab (3.0-1build1) ...
Selecting previously unselected package python-xlrd.
Preparing to unpack .../python-xlrd_0.9.2-1_all.deb ...
Unpacking python-xlrd (0.9.2-1) ...
Selecting previously unselected package python-xlwt.
Preparing to unpack .../python-xlwt_0.7.5+debian1-1_all.deb ...
Unpacking python-xlwt (0.7.5+debian1-1) ...
Selecting previously unselected package zlib1g-dev:i386.
Preparing to unpack .../zlib1g-dev_1%3a1.2.8.dfsg-1ubuntu1_i386.deb ...
Unpacking zlib1g-dev:i386 (1:1.2.8.dfsg-1ubuntu1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libwebpmux1:i386 (0.4.0-4) ...
Setting up libapache2-mod-wsgi (3.4-4ubuntu2.1.14.04.2) ...
apache2_invoke: Enable module wsgi
 * Restarting web server apache2
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
   ...done.
Setting up python-antlr (2.7.7+dfsg-5) ...
Setting up python-pil (2.3.0-1ubuntu3) ...
Setting up python-imaging (2.3.0-1ubuntu3) ...
Setting up python-lxml (3.3.3-1ubuntu0.1) ...
Setting up python-reportlab-accel (3.0-1build1) ...
Setting up python-reportlab (3.0-1build1) ...
Setting up python-xlrd (0.9.2-1) ...
Setting up python-xlwt (0.7.5+debian1-1) ...
Setting up zlib1g-dev:i386 (1:1.2.8.dfsg-1ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.5) ...
python: no process found
dropdb: database removal failed: ERROR:  database "sahana" does not exist
Cloning into 'web2py'...
Cloning into 'eden'...
Checking out files:  47% (3752/7842)   
Checking out files:  48% (3765/7842)   
Checking out files:  49% (3843/7842)   
Checking out files:  50% (3921/7842)   
Checking out files:  51% (4000/7842)   
Checking out files:  52% (4078/7842)   
Checking out files:  53% (4157/7842)   
Checking out files:  54% (4235/7842)   
Checking out files:  55% (4314/7842)   
Checking out files:  56% (4392/7842)   
Checking out files:  57% (4470/7842)   
Checking out files:  58% (4549/7842)   
Checking out files:  59% (4627/7842)   
Checking out files:  60% (4706/7842)   
Checking out files:  61% (4784/7842)   
Checking out files:  62% (4863/7842)   
Checking out files:  63% (4941/7842)   
Checking out files:  64% (5019/7842)   
Checking out files:  65% (5098/7842)   
Checking out files:  66% (5176/7842)   
Checking out files:  67% (5255/7842)   
Checking out files:  68% (5333/7842)   
Checking out files:  69% (5411/7842)   
Checking out files:  69% (5434/7842)   
Checking out files:  70% (5490/7842)   
Checking out files:  71% (5568/7842)   
Checking out files:  72% (5647/7842)   
Checking out files:  73% (5725/7842)   
Checking out files:  74% (5804/7842)   
Checking out files:  75% (5882/7842)   
Checking out files:  76% (5960/7842)   
Checking out files:  77% (6039/7842)   
Checking out files:  78% (6117/7842)   
Checking out files:  79% (6196/7842)   
Checking out files:  80% (6274/7842)   
Checking out files:  81% (6353/7842)   
Checking out files:  82% (6431/7842)   
Checking out files:  82% (6476/7842)   
Checking out files:  83% (6509/7842)   
Checking out files:  84% (6588/7842)   
Checking out files:  85% (6666/7842)   
Checking out files:  86% (6745/7842)   
Checking out files:  87% (6823/7842)   
Checking out files:  88% (6901/7842)   
Checking out files:  89% (6980/7842)   
Checking out files:  90% (7058/7842)   
Checking out files:  91% (7137/7842)   
Checking out files:  92% (7215/7842)   
Checking out files:  92% (7287/7842)   
Checking out files:  93% (7294/7842)   
Checking out files:  94% (7372/7842)   
Checking out files:  95% (7450/7842)   
Checking out files:  96% (7529/7842)   
Checking out files:  97% (7607/7842)   
Checking out files:  98% (7686/7842)   
Checking out files:  99% (7764/7842)   
Checking out files: 100% (7842/7842)   
Checking out files: 100% (7842/7842), done.
The user `user' is already a member of `users'.
cp: cannot stat '/usr/local/lib/web2py/applications/eden/private/templates/000_config.py': No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/models/000_config.py: No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/models/000_config.py: No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/models/000_config.py: No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/models/000_config.py: No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/private/templates/default/gis_config.csv: No such file or directory
sed: can't read /usr/local/lib/web2py/applications/eden/private/templates/default/gis_config.csv: No such file or directory

WARNING:  Setup unresolved dependency: boto required for Setup Module
WARNING:  S3Doc unresolved dependency: pyth required for RTF document support in Full-Text Search
WARNING:  S3Doc unresolved dependency: sunburnt required for Full-Text Search support
WARNING:  S3GIS unresolved dependency: selenium required for Map printing support
WARNING:  Setup unresolved dependency: PyYAML required for Setup Module
WARNING:  Setup unresolved dependency: ansible required for Setup Module
WARNING:  Survey unresolved dependency: PyRTF required if you want to export assessment/survey templates as a Word document
WARNING: Unresolved optional dependency: pyserial required
WARNING:  S3Msg unresolved dependency tweepy required for non-Tropo Twitter support
WARNING:  Message Parsing unresolved dependency: TwitterSearch required for fetching results from twitter keyword queries

ACTION REQUIRED: The following files were copied from templates and should be edited: models/000_config.py
web2py Web Framework
Created by Massimo Di Pierro, Copyright 2007-2015
Version 2.9.12-beta+timestamp.2015.01.12.21.00.43
Database drivers available: sqlite2, sqlite3, pymysql, psycopg2, pg8000, pyodbc, imaplib
Traceback (most recent call last):
  File "web2py.py", line 33, in <module>
    gluon.widget.start(cron=True)
  File "/usr/local/lib/web2py/gluon/widget.py", line 1128, in start
    cronjob=options.cronjob)
  File "/usr/local/lib/web2py/gluon/shell.py", line 237, in run
    _env = env(a, c=c, f=f, import_models=import_models, extra_request=extra_request)
  File "/usr/local/lib/web2py/gluon/shell.py", line 162, in env
    run_models_in(environment)
  File "/usr/local/lib/web2py/gluon/compileapp.py", line 569, in run_models_in
    restricted(code, environment, layer=model)
  File "/usr/local/lib/web2py/gluon/restricted.py", line 224, in restricted
    exec ccode in environment
  File "applications/eden/models/000_1st_run.py", line 62, in <module>
    raise HTTP(500, body=html)
gluon.http.HTTP: 500 INTERNAL SERVER ERROR

WARNING:  Setup unresolved dependency: boto required for Setup Module
WARNING:  S3Doc unresolved dependency: pyth required for RTF document support in Full-Text Search
WARNING:  S3Doc unresolved dependency: sunburnt required for Full-Text Search support
WARNING:  S3GIS unresolved dependency: selenium required for Map printing support
WARNING:  Setup unresolved dependency: PyYAML required for Setup Module
WARNING:  Setup unresolved dependency: ansible required for Setup Module
WARNING:  Survey unresolved dependency: PyRTF required if you want to export assessment/survey templates as a Word document
WARNING: Unresolved optional dependency: pyserial required
WARNING:  S3Msg unresolved dependency tweepy required for non-Tropo Twitter support
WARNING:  Message Parsing unresolved dependency: TwitterSearch required for fetching results from twitter keyword queries

ACTION REQUIRED: Please edit 000_config.py before starting the system.
web2py Web Framework
Created by Massimo Di Pierro, Copyright 2007-2015
Version 2.9.12-beta+timestamp.2015.01.12.21.00.43
Database drivers available: sqlite2, sqlite3, pymysql, psycopg2, pg8000, pyodbc, imaplib
Traceback (most recent call last):
  File "web2py.py", line 33, in <module>
    gluon.widget.start(cron=True)
  File "/usr/local/lib/web2py/gluon/widget.py", line 1128, in start
    cronjob=options.cronjob)
  File "/usr/local/lib/web2py/gluon/shell.py", line 237, in run
    _env = env(a, c=c, f=f, import_models=import_models, extra_request=extra_request)
  File "/usr/local/lib/web2py/gluon/shell.py", line 162, in env
    run_models_in(environment)
  File "/usr/local/lib/web2py/gluon/compileapp.py", line 569, in run_models_in
    restricted(code, environment, layer=model)
  File "/usr/local/lib/web2py/gluon/restricted.py", line 224, in restricted
    exec ccode in environment
  File "applications/eden/models/000_1st_run.py", line 62, in <module>
    raise HTTP(500, body=html)
gluon.http.HTTP: 500 INTERNAL SERVER ERROR
VACUUM
chown: cannot access '/usr/local/lib/web2py/applications/eden/compiled/': No such file or directory
chown: cannot access '/usr/local/lib/web2py/applications/eden/databases/*': No such file or directory
chmod: cannot access '/usr/local/lib/web2py/applications/eden/databases/*': No such file or directory
chown: cannot access '/usr/local/lib/web2py/applications/eden/cache/*': No such file or directory
chmod: cannot access '/usr/local/lib/web2py/applications/eden/cache/*': No such file or directory
chown: cannot access '/usr/local/lib/web2py/applications/eden/models/0000_update*.py': No such file or directory
chmod: cannot access '/usr/local/lib/web2py/applications/eden/models/0000_update*.py': No such file or directory
Enabling module proxy.
To activate the new configuration, you need to run:
  service apache2 restart
Considering dependency proxy for proxy_http:
Module proxy already enabled
Enabling module proxy_http.
To activate the new configuration, you need to run:
  service apache2 restart
Enabling conf sahana.
To activate the new configuration, you need to run:
  service apache2 reload
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
===============================================================
Finished "install_sahana.sh"
Disk Usage1: install_sahana.sh,Filesystem,1K-blocks,Used,Available,Use%,Mounted_on,date
Disk Usage2: install_sahana.sh,-,40259,10631,27565,28%,/,2015-01-14 19:13:39+00:00
Temp Usage: install_sahana.sh,1071	/tmp
===============================================================

comment:3 Changed 5 years ago by kalxas

Resolution: fixed
Status: newclosed

After reverting to a working commit number in [12197], everything is working again in latest nightly build.

Note: See TracTickets for help on using tickets.