Opened 5 years ago

Closed 5 years ago

#1456 closed defect (fixed)

EOxServer image preview not working

Reported by: kalxas Owned by: live-demo@…
Priority: major Milestone: OSGeoLive8.5
Component: OSGeoLive Keywords: eoxserver
Cc: live-demo@…

Description

After the upgrade to EOxServer 4.0, in the new demo map client, the image preview does not show up.

There was a fix in svn [12171], downgrading django (and installing locally through pip) in order for this bug to be fixed.

This solution is not acceptable IMO (thus reverted in [12173]) since:

  1. Previous EOxServer stable version (0.3.2) was working fine with Ubuntu version of django.
  2. The upstream version of django is also used by other projects in the disk and should not be changed.
  3. We are over our disk space budget and we cannot afford frameworks to be installed twice.

My proposal is either for us to fix EOxServer 0.4 to work with upstream django version or roll back to the previous EOxServer 0.3.2 release for this version of the Live.

Thoughts?

Change history (4)

comment:1 Changed 5 years ago by fschindler

Yes, indeed, EOxServer 0.4 seems to run into errors that did not show up in earlier versions of Django. (It works fine with 1.5.*) I opened a ticket (https://github.com/EOxServer/eoxserver/issues/300) to track this issue and already had a look into it. Unfortunately the issue is related to the data models of EOxServer, which I am hesitatant to change for the 0.4 release (as it will likely have consequences on various other parts of the code).

It really bugs me, but I think with the (understandably) tight restrictions there is no other option than to revert to 0.3.2 and provide a fix for the next release.

comment:2 Changed 5 years ago by kalxas

I am looking how to downgrade eoxserver deb package inside our nightly PPA.

comment:3 Changed 5 years ago by kalxas

ok, I managed to revert our nightly ppa to EOxServer 0.3.2.

@fschindler can you please make sure that the installation script works with 0.3.2?

comment:4 Changed 5 years ago by kalxas

Resolution: fixed
Status: newclosed

Thanks fschindler, Everything is now working again.

Note: See TracTickets for help on using tickets.