Opened 6 years ago

Closed 6 years ago

#1285 closed defect (wontfix)

python Iris

Reported by: darkblueb Owned by: live-demo@…
Priority: major Milestone: OSGeoLive7.9
Component: OSGeoLive Keywords: python, Iris
Cc:

Description

the (extensive) Iris library is currently at 1.40; there are compatibility questions about Iris and matplotlib, and the rest of the SciPy? stack.

Attachments (3)

iris_140_nosetests.txt (57.3 KB) - added by darkblueb 6 years ago.
py_install_compare.tgz (11.0 KB) - added by darkblueb 6 years ago.
step by step compare of install_ipython.sh steps: freeze_* is existing order; freeze2_ is alternate order using jtaylor repo iPython before pip install -U numpy/pandas/matplotlib
synaptic-b3-local.png (139.9 KB) - added by darkblueb 6 years ago.

Download all attachments as: .zip

Change history (16)

comment:1 Changed 6 years ago by darkblueb

running {{{ user@live79a-11018:/usr/local/lib/python2.7/dist-packages/Iris-1.4.0-py2.7-linux-x86_64.egg/iris/tests$ nosetests }}} presents mixed results (see attachment)

Changed 6 years ago by darkblueb

Attachment: iris_140_nosetests.txt added

comment:2 Changed 6 years ago by darkblueb

these are the test failures:

FAIL: test_positive (iris.tests.analysis.test_interpolate.Test_linear__circular_wrapping)
FAIL: test_symmetric (iris.tests.analysis.test_interpolate.Test_linear__circular_wrapping)
FAIL: test_contrived_non_spherical_curl2 (iris.tests.test_analysis_calculus.TestCalculusWKnownSolutions)
FAIL: test_AuxCoord_str (iris.tests.test_coord_api.TestCoord_ReprStr_time)
FAIL: test_DimCoord_str (iris.tests.test_coord_api.TestCoord_ReprStr_time)
FAIL: test_add_season_nonstandard (iris.tests.test_coord_categorisation.TestCategorisations)
FAIL: test_circular_vs_non_circular_coord (iris.tests.test_interpolation.TestLinear1dInterpolation)
FAIL: test_simple_multiple_points_circular (iris.tests.test_interpolation.TestLinear1dInterpolation)
FAIL: test_levels_below_ground (iris.tests.test_nimrod.TestLoad)
FAIL: test_orography (iris.tests.test_nimrod.TestLoad)
FAIL: test_period_of_interest (iris.tests.test_nimrod.TestLoad)
FAIL: test_copy_float_false (iris.tests.test_pandas.TestAsDataFrame)
FAIL: test_copy_int32_false (iris.tests.test_pandas.TestAsDataFrame)
FAIL: test_copy_int64_false (iris.tests.test_pandas.TestAsDataFrame)
FAIL: test_time_gregorian (iris.tests.test_pandas.TestAsDataFrame)
FAIL: test_masked (iris.tests.test_pandas.TestAsSeries)
FAIL: test_no_dim_coord (iris.tests.test_pandas.TestAsSeries)
FAIL: test_simple (iris.tests.test_pandas.TestAsSeries)
FAIL: test_time_360 (iris.tests.test_pandas.TestAsSeries)
FAIL: test_time_gregorian (iris.tests.test_pandas.TestAsSeries)

comment:3 Changed 6 years ago by kalxas

Priority: normalmajor

comment:4 Changed 6 years ago by darkblueb

I am looking at the yaml build instructions for a Travis instance, here

iris_1_6_travis_setup

I can see many, very specific library requirements.. I see that this Iris project is a) very active, b) challenged by the number of small libraries it requires ..

I suspect that Iris development emphasis is on Trusty, perhaps even python3 now. However.. the OSGeo Live does get a wide audience.. if this Iris library is important enough for the UK Met to put this much effort into development, perhaps it is important enough to resolve these challenges on the Live, not simply declare "release it in September 2014"

SOLUTION ?

If install_iris.sh works with matplotlib 1.2+, and the changes to install_ipython.sh are accepted, then we are done.

If someone from the Iris project does show up and make improvements, to bring Iris up to 1.6, better. But from the yaml file above, it seems likely that there are too many small requirements for that to happen easily.

comment:5 Changed 6 years ago by darkblueb

apt-get install python-matplotlib => matplotlib 1.1.1rc

which satisfies none..

comment:6 Changed 6 years ago by darkblueb

pip install -U matplotlib => matplotlib 1.3.1

Changed 6 years ago by darkblueb

Attachment: py_install_compare.tgz added

step by step compare of install_ipython.sh steps: freeze_* is existing order; freeze2_ is alternate order using jtaylor repo iPython before pip install -U numpy/pandas/matplotlib

comment:7 Changed 6 years ago by darkblueb

Addressing the question of "Iris 1.4 compatability with Matplotlib == 1.2 and matplotlib == 1.3.1"

ran nosetests on each config both setups result in some skipped, some failed tests.. 10-to-1 passing in both cases. Support libraries play a large role as many tests rely on them.

In any case, there is no escaping this: matplotlib 1.2 is required, so some pip is required. (see above)

comment:8 Changed 6 years ago by darkblueb

yet another repository is here:

drescampbell

comment:9 Changed 6 years ago by hamish

Hi Brian,

we had a lengthy discussion about this last year around Iris needing a newer matplotlib than the standard ubuntu packages provided, and how that might interfere with the other packages on the disc which were expecting the stock version of it. IIRC the result was to install the version iris wanted, cross our fingers and hope for the best!

best, Hamish

comment:10 Changed 6 years ago by darkblueb

I aim to show by testing that this configuration is solid.

comment:11 Changed 6 years ago by darkblueb

user@live-79b2:~$ git clone https://github.com/SciTools/iris-test-data.git

Changed 6 years ago by darkblueb

Attachment: synaptic-b3-local.png added

comment:12 Changed 6 years ago by kalxas

Is this still an issue? Did someone check Iris on beta3?

comment:13 Changed 6 years ago by ian

Resolution: wontfix
Status: newclosed

I tested just before this weekend and Iris was functioning correctly. I was happy that the errors from the automatic tests were not critical (some tests will fail in 32-bit environments etc). It looks like the wider compatibility questions will be addressed in the 8.0 release. I've resolved this issue as 'wontfix'

http://trac.osgeo.org/osgeo/ticket/1305 is new and could be a problem.

Note: See TracTickets for help on using tickets.