Opened 6 years ago

Closed 6 years ago

#1281 closed defect (fixed)

osm2pgrouting missing

Reported by: kalxas Owned by: live-demo@…
Priority: critical Milestone: OSGeoLive7.9
Component: OSGeoLive Keywords:
Cc:

Description

ldconfig deferred processing now taking place
E: Package 'osm2pgrouting' has no installation candidate
create pgrouting database with PostGIS and pgRouting
createdb: database creation failed: ERROR:  new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
HINT:  Use the same encoding as in the template database, or use template0 as template.
psql: FATAL:  database "pgrouting" does not exist
psql: FATAL:  database "pgrouting" does not exist
unpack sample data
Run osm2pgrouting converter (this may take a while)
sudo: osm2pgrouting: command not found
psql: FATAL:  database "pgrouting" does not exist

Change history (15)

comment:1 Changed 6 years ago by kalxas

Milestone: OSGeoLive7.9

comment:2 Changed 6 years ago by hamish

Owner: changed from live-demo@… to hamish
Status: newassigned

comment:3 Changed 6 years ago by kalxas

@hamish, welcome back :)

comment:4 Changed 6 years ago by dkastl

You can get the package from this repository: https://launchpad.net/~georepublic/+archive/pgrouting

comment:5 Changed 6 years ago by kalxas

Thanks dkastl, I copied the deb package. Testing on next nightly

comment:6 Changed 6 years ago by kalxas

in [11061] :

Unpacking osm2pgrouting (from .../osm2pgrouting_2.0.0-release-ppa1~precise1_i386.deb) ...
Setting up osm2pgrouting (2.0.0-release-ppa1~precise1) ...
create pgrouting database with PostGIS and pgRouting
CREATE EXTENSION
CREATE EXTENSION
unpack sample data
Run osm2pgrouting converter (this may take a while)
sudo: osm2pgrouting: command not found
VACUUM

comment:7 Changed 6 years ago by hamish

Cc: live-demo@… removed
Owner: changed from hamish to live-demo@…
Status: assignednew

comment:8 Changed 6 years ago by dkastl

I would really appreciate, if the person, who commented out the previous PPA for pgRouting also makes sure, that the install script still works.

It would have been quite easy then to see, that osm2pgrouting was not copied to the OSGeoLive PPA.

So possible solutions are:

  • (1) Re-enable the PPA with osm2pgrouting (ppa:georepublic/pgrouting)
  • (2) Copy the osm2pgrouting package to the PPA, which is used now.

(1) I can do, (2) I can't.

Regards, Daniel

For reference the relevant lines in "install_pgrouting.sh":

# TODO: Remove third party PPAs
#add-apt-repository -y ppa:georepublic/pgrouting
apt-get update -qq

# Install pgRouting packages
apt-get install -y -qq postgresql-9.3-pgrouting
	
if [ $? -ne 0 ] ; then
   echo 'ERROR: pgRouting Package install failed! Aborting.'
   exit 1
fi

# Install osm2pgrouting package
apt-get install -y -qq osm2pgrouting

comment:9 Changed 6 years ago by kalxas

The problem is that the deb was copied several weeks ago and osm2pgrouting still is not picked up

https://launchpad.net/~osgeolive/+archive/nightly/+sourcepub/3889394/+listing-archive-extra "Published on 2014-02-03"

comment:10 Changed 6 years ago by kalxas

Does the ppa:georepublic/pgrouting use PostgreSQL 9.3 as a build target? If not solution (1) is not an option.

comment:11 Changed 6 years ago by dkastl

It seems I found out where the problem lies: osm2pgrouting binary goes to /usr/share/bin and not /usr/bin

I will publish an updated package in the next hours.

comment:12 Changed 6 years ago by kalxas

Thanks.

comment:13 Changed 6 years ago by dkastl

An updated package of osm2pgrouting has been published in "ppa:georepublic/pgrouting" and can be copied into OSGeoLive nightly builds PPA.

It should fix this ticket.

comment:14 Changed 6 years ago by kalxas

Files copied. Thanks. Waiting for next nightly now.

comment:15 Changed 6 years ago by kalxas

Resolution: fixed
Status: newclosed

Fixed in [11138]

Note: See TracTickets for help on using tickets.