Opened 3 years ago

Closed 2 years ago

#650 closed defect (fixed)

msodbcsql - unknown package

Reported by: tobwen Owned by: osgeo4w-dev@…
Priority: minor Component: Installer
Version: Keywords:


## tl;dr For about two weeks, I'm getting this error on two machines after installation is done:

Package: Unknown package
	msodbcsql.bat exit code 1603

ogr2ogr also chokes on this:

ERROR 1: Can't load requested DLL: C:\OSGEO4~1\bin\gdalplugins\ogr_MSSQLSpatial.dll
126: Das angegebene Modul wurde nicht gefunden.

Change History (5)

comment:1 by jef, 3 years ago

Anything in var/log/setup.log{,.full}? Try installing {{bin\msodbcsql.msi}} manually to see what errors appear.

comment:2 by tobwen, 3 years ago

Normal log

2020/11/11 21:34:54 running: cmd.exe /c "C:\OSGeo4W64\\etc\postinstall\msodbcsql.bat"
2020/11/11 21:34:55 abnormal exit: exit code=1603
2020/11/11 23:00:04 note: Installation abgeschlossen
2020/11/11 23:00:04 Ending OSGeo4W install

Full log

2020/11/11 21:34:54 running: cmd.exe /c "C:\OSGeo4W64\\etc\postinstall\msodbcsql.bat"
C:\OSGeo4W64>msiexec /i C:\OSGeo4W64\bin\msodbcsql.msi /qn IACCEPTMSOLEDBSQLLICENSETERMS=YES 
2020/11/11 21:34:55 abnormal exit: exit code=1603

I tried

msiexec /i "C:\OSGeo4W64\bin\msodbcsql.msi" /qn IACCEPTSQLNCLILICENSETERMS=YES /log logfile.txt

and got this log: (I'll append a file if it works this time)

Seems like it's a rights problem?

comment:3 by tobwen, 3 years ago

I'm running the OSGeo4W installer as admin, of course (using UAC)

comment:4 by jonnyforest, 3 years ago

Hi guys, I had the same problem. I did e fresh install with OSGeo4W64 using UAC and the log showed:

2020/11/11 09:34:46 running: cmd.exe /c "C:\OSGeo4W64\\etc\postinstall\msodbcsql.bat"
2020/11/11 09:34:47 abnormal exit: exit code=1603

I had as well the same issue in the commandline of osgeo shell-

I went to the bin folder and did a manual install of msi (right-click open as administrator) and the problem was solved.

If I try to install using the msiexec method I have the same problem of tobwen.

I did a quick search about exit code=1603 and can be about permissions or corrupted .msi

I found this link: explain a possible cause. Old versions install, perhaps?

Last edited 3 years ago by jonnyforest (previous) (diff)

comment:5 by jef, 2 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.