Opened 13 years ago

Closed 8 years ago

#61 closed defect (worksforme)

Dependencies not automatically selected

Reported by: cnielsen Owned by: osgeo4w-dev@…
Priority: major Component: Installer
Version: Keywords: grass
Cc: Guillaume Huby

Description

For package version: grass-6.4.0RC3-2 Several required packages were not automatically selected including: curl, expat, hdf5, geos, libjpeg, libmysql, libpq, netcdf, ogdi, and xerces-c.

Without them an error occurred on: g.region -p

(wasn't sure if this was an installer issue or a package issue)

Change History (12)

comment:1 by hamish, 13 years ago

note that all those (except for curl?) are actually GDAL dependencies, not directly GRASS ones.

Hamish

comment:2 by hamish, 13 years ago

Keywords: grass added

comment:3 by cnielsen, 13 years ago

Summary: Missing dependencies for Grass-6.4.0RC3-2Dependencies not automatically selected

Quite right (and curl is a gdal dependency too). I completely wiped the osgeo4w directory to start again, and it turns out the problem is that no dependencies are selected at all. I used a new empty directory with a just downloaded version of the installer. However, I haven't been able to replicate this on other computers.

comment:4 by warmerdam, 13 years ago

I would love to know a set of steps to reproduce this. I frequently wipe the C:\OSGeo4W tree on machines, and then reinstall and I have no problem with dependencies not being selected so I don't understand why some people do seem to run into this.

comment:5 by hamish, 13 years ago

In http://download.osgeo.org/osgeo4w/setup.ini both gdal and gdal16 both "requires:" curl, expat, etc. so it doesn't seem to be a packaging mistake, more of a cygwin installer problem...?

perhaps if the downloads get interrupted part way through the install process it continues anyway with what it's got??

ISTR we've seen a very similar problem with the GRASS cygwin installer in the past.

Hamish

comment:6 by cnielsen, 13 years ago

I finally managed to reproduce this (accidentally). I was deleting the osgeo4w tree as I opened the installer to re-install from scratch. Presumably some file got deleted as it was being used, or written and then erased, etc. By restoring the /osgeo4w/etc and /osgeo4w/var directories from the trash I managed to reverse the effect, and by copying those folders to another affected computer I was able to fix that one too. I'm still not sure which file in those folders was responsible, or why erasing the entire osgeo4w tree (without starting the installer) did not fix the problem.

comment:7 by cnielsen, 13 years ago

On further investigation it appears to be the \OSGeo4W\etc\setup\installed.db file that is causing the problems.

comment:8 by warmerdam, 13 years ago

The installer loads the installed.db file contents at startup and writes them back out when it terminates. This causes significant problems if you delete the OSGeo4W tree while the installer is running - mostly because it saves an installed.db file indicating many packages are installed that are not actually installed.

For now the only advice I have is to ensure that the installer is terminated before clearing the tree.

comment:9 by cnielsen, 13 years ago

This can be resolved by removing the registry entries written by the osgeo installer:

[-HKEY_LOCAL_MACHINE\Software\OSGeo] [-HKEY_CURRENT_USER\Software\OSGeo]

Or for win64 [-HKEY_LOCAL_MACHINE\Software\Wow6432Node\OSGeo] [-HKEY_CURRENT_USER\Software\OSGeo]

Although an uncommon problem, perhaps something could be changed in the osgeo4w installer to stop it from reading the registry if no installed.db file is found.

in reply to:  9 comment:10 by cnielsen, 13 years ago

Replying to cnielsen:

This can be resolved by removing the registry entries written by the osgeo installer:

My mistake, this doesn't resolve the issue. This forces the installer to download the grass package but still no dependencies are selected.

To be clear, once the problem begins, even with the installer not running, clearing the tree does not resolve this issue.

comment:11 by Guillaume Huby, 12 years ago

Cc: Guillaume Huby added

Hello,

I met exatcly the same problem. The computer is using Windows XP Pro x64 Edition Version 2003 SP2. OSGeo4W had never been installed before on this computer.

I downloaded the setup from the web site (30/06/2010).

I choosed "advanced installation".

When I check "gdal" box, no dependency is set.

I checked the setup.ini file which looks complete.

I installed OSGeo4W on other computers without any problem before (some months before).

comment:12 by jef, 8 years ago

Resolution: worksforme
Status: newclosed

I think this was recently fixed with the merge of the cygwin installer. Dependencies are now added after the desired packages have been selected.

Note: See TracTickets for help on using tickets.