Opened 13 years ago

Closed 11 years ago

#60 closed defect (fixed)

QGIS Start menu shortcut doesn't work with non-default install directory

Reported by: Mike Taves Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: qgis
Cc:

Description

My setup is installed in a non-default location C:\gnu\OSGeo4W

The Start menu item has the correct target (with 2 extra spaces at end??):

C:\gnu\OSGeo4W\bin\qgis.bat  

however, when it is selected from the Start menu, I see an error in a cmd console:

The system cannot find the path specified.

and a Windows dialog with "Windows cannot find 'C:\OSGEO4W\apps\qgis\bin\qgis.exe'."

The problem is with qgis.bat:

@echo off
SET OSGEO4W_ROOT=C:\OSGeo4W
call "%OSGEO4W_ROOT%"\bin\o4w_env.bat
@echo off
set GDAL_DRIVER_PATH=%OSGEO4W_ROOT%\bin\gdalplugins
start "Quantum GIS" /B "%OSGEO4W_ROOT%"\apps\qgis\bin\qgis.exe %*

since it assumes that OSGEO4W_ROOT=C:\OSGeo4W which is not always true.

Change History (1)

comment:1 by jef, 11 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.