#563 closed defect (fixed)

Bundle Python version is outdated in OSGeo4w package

Reported by: JLiang Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: Python SSL


Please consider upgrading Python to 2.7.10 or above in OSGeo4W

Current Python version in OSGeo4W is 2.7.5 (QGIS 2.18) However, TLSv1_2 wasn't added until Python 2.7.9.

For some API provider, like Github, they started to move to supporting TLS1.2, also requires that the Client's Hello Message carries with a server name indication (SNI), otherwise server end would reject.

Also it is likely that more and more web services will switch to TLS1.2, please consider upgrading the Python version (in the bundle package) at least to 2.7.10 or even higher.

In order to verify that, try in python console: import json, urllib2; print json.load(urllib2.urlopen('​https://api.github.com/')) The situation is almost the same with Requests library.

It is not easy for Windows users workaround this SSL version problem, provided we continue using Python 2.7.5 in OSGeo4W.

Attachments (1)

image001.png (32.4 KB) - added by JLiang 21 months ago.

Download all attachments as: .zip

Change History (4)

Changed 21 months ago by JLiang

Attachment: image001.png added

comment:1 Changed 20 months ago by plimkilde

Also, an additional problem with the old 2.7.5 version I've run into is that unit tests using the multiprocessing module may cause infinite process spawning on Windows. This should be fixed in Python 2.7.11+. (Python issue: https://bugs.python.org/issue10128)

comment:2 Changed 18 months ago by lpinner

I've also found that pip installs no longer work with python 2.7.5 because of the lack of TLS1.2 support.


comment:3 Changed 10 months ago by jef

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.