#562 closed defect (fixed)

Bundle Python version is outdated in OSGeo4w package

Reported by: JLiang Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: Python SSL
Cc:

Description

Please consider upgrading Python to 2.7.10 or above in OSGeo4W

Current Python version in OSGeo4W is 2.7.5 (QGIS 2.18) However, TLSv1_2 wasn't added until Python 2.7.9.

For some API provider, like Github, they started to move to supporting TLS1.2, also requires that the Client's Hello Message carries with a server name indication (SNI), otherwise server end would reject.

Also it is likely that more and more web services will switch to TLS1.2, please consider upgrading the Python version (in the bundle package) at least to 2.7.10 or even higher.

In order to verify that, try in python console: import json, urllib2; print json.load(urllib2.urlopen('​https://api.github.com/')) it is very much the same with Requests library.

It is not easy to workaround this SSL version problem, provided we continue using Python 2.7.5 in OSGeo4W.

Attachments (1)

image001.png (32.4 KB) - added by JLiang 21 months ago.

Download all attachments as: .zip

Change History (2)

Changed 21 months ago by JLiang

Attachment: image001.png added

comment:1 Changed 10 months ago by jef

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.