Opened 4 years ago

Closed 10 months ago

#555 closed enhancement (fixed)

Upgrade request for PyQt4 in order to fix deprecation warnings in QGIS

Reported by: andreaerdna Owned by: osgeo4w-dev@…
Priority: minor Component: Package
Version: Keywords: pyqt pyqt4
Cc:

Description (last modified by andreaerdna)

Some plugins (e.g. go2streeview) rely on uiparser.py of PyQt4.

Readresources in uiparser.py of PyQt4 < 4.11.4 uses the old deprecated feature elem.getiterator, that now is pending for removal (see https://bugs.python.org/issue29209) from Python and generates the following Python warning in QGIS 2.18.17:

C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\PyQt4\uic\uiparser.py:844:
PendingDeprecationWarning: This method will be removed in future versions.
Use 'elem.iter()' or 'list(elem.iter())' instead.
...

So, please upgrade PyQt4 (now in OSGeo4W is x86:4.11.3-1 18-Oct-2017 | x86_64:4.10.2-1 16-Jun-2013) to a version >= 4.11.4.

Change History (2)

comment:1 Changed 4 years ago by andreaerdna

Description: modified (diff)

comment:2 Changed 10 months ago by jef

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.