Opened 5 years ago

Closed 5 years ago

#535 closed defect (fixed)

Problem with QGIS and gdal 2.2.0-5

Reported by: PedroNGV Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: gdal, qgis, osgeo4w
Cc:

Description

Hi,

I've updated today QGIS from OSGeo4W64bits and it updated also gdal to version 2.2.0-5.

It lead to a constant and inconsistent QGIS crash, sometimes at the start, other times when openning some saved projects, and other times, with new projects, when editing data, or simply zooming in and out.

Tested with QGIS 2.18.9-14 and 2.14.15-5, with and without GRASS plugin. Also starting with --noplugins, I get the crash.

Then I did the downgrade of gdal to 2.2.0-3, and everything seems to work again.

To confirm, I've installed again gdal 2.2.0-5, tested, and get the crash right at the QGIS start. Downgraded again to gdal 2.2.0-3 and I get everything working again.

So, it seems to be something wrong with QGIS and gdal 2.2.0-5.

Change History (3)

comment:1 Changed 5 years ago by jef

Crashed in libtiff - switched to internal tiff/geotiff in GDAL.

Last edited 5 years ago by jef (previous) (diff)

comment:2 in reply to:  1 Changed 5 years ago by PedroNGV

Should this be fixed @jef?

I tested today with gdal 2.2.0-6 and it seems fixed.

Thanks!

comment:3 Changed 5 years ago by jef

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.