Opened 3 years ago

Closed 3 years ago

#516 closed defect (worksforme)

no vector menu tools are available

Reported by: saultdon Owned by: osgeo4w-dev@…
Priority: blocker Component: Package
Version: Keywords: qgis 2.16
Cc:

Description

Looks like the vector menu in QGIS 2.16 is missing some gdal entries maybe.

Entries not there are: Research Tools, Geoprocessing Tools, Geometry Tools, Analysis Tools, and Data Management Tools.

Change History (3)

comment:1 Changed 3 years ago by AndreJoost

This is not a bug of OSGEO4W, but a strange feature of QGIS 2.16.

Overriding the locale with US English, the GDAL menu entries are present.

Changing locale back to my OS (German), I have a second vector menu behind the Help Menu. The First Vector menu only has Openstreetmap, while the second has the GDAL commands.

See https://hub.qgis.org/issues/15265 for the corresponding ticket from hub.qgis.org.

Tested on Ubuntu and Windows, so not an OSGeo4W packaging problem.

Last edited 3 years ago by AndreJoost (previous) (diff)

comment:2 Changed 3 years ago by saultdon

OK, figured it out.

With QGIS 2.16, Processing is a core plugin now. Saw some comments from Arch Linux users about this.

Users when upgrading should delete the processing plugin folder in their Users or Home folder.

On Windows it could be: C:\Users\username\.qgis2\python\plugins\processing On Linux it's: /home/username/.qgis2/python/plugins/processing

Once I deleted the old processing plugin folder, menu entries are back!

This report can be closed, thanks for your time! Oh, and it looks like that's described int the link you provided as well =)

Last edited 3 years ago by saultdon (previous) (diff)

comment:3 Changed 3 years ago by jef

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.