Opened 6 years ago

Closed 6 years ago

#515 closed defect (duplicate)

python support disabled in qgis - no module named future

Reported by: saultdon Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: qgis
Cc:

Description

I just upgraded QGIS to 2.16.0 from the OSGeo4W installer and it starts with a python error.

Couldn't load QGIS utils.
Python support will be disabled.


Traceback (most recent call last):
  File "", line 1, in 
  File "C:/GIS/Apps/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 20, in 
    from future import standard_library
ImportError: No module named future


Python version:
2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)]

QGIS version:
2.16.0-Nødebo 'Nødebo', d0b3e39

Python path:
['C:/GIS/Apps/OSGEO4~1/apps/qgis/./python', u'C:/Users/dcameron/.qgis2/python', u'C:/Users/dcameron/.qgis2/python/plugins', 'C:/GIS/Apps/OSGEO4~1/apps/qgis/./python/plugins', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\matplotlib-1.3.1-py2.7-win-amd64.egg', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\nose-1.3.3-py2.7.egg', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\tornado-4.0.1-py2.7-win-amd64.egg', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\backports.ssl_match_hostname-3.4.0.2-py2.7.egg', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\certifi-14.05.14-py2.7.egg', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\orfeotoolbox\\python', 'C:\\GIS\\Apps\\OSGEO4~1\\bin', 'C:\\GIS\\Apps\\OSGEO4~1\\bin\\python27.zip', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\DLLs', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\plat-win', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\lib-tk', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\PIL', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\jinja2-2.7.2-py2.7.egg', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\markupsafe-0.23-py2.7-win-amd64.egg', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\pytz-2012j-py2.7.egg', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\win32', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\win32\\lib', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\Pythonwin', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\Shapely-1.2.18-py2.7-win-amd64.egg', 'C:\\GIS\\Apps\\OSGEO4~1\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode']

I think python-future in the installer just needs to be added as a dependency.

Change History (1)

comment:1 by jef, 6 years ago

Resolution: duplicate
Status: newclosed

duplicate of #514

Note: See TracTickets for help on using tickets.