Opened 13 years ago

Closed 14 months ago

#47 closed enhancement (outdated)

Start menu is disorganized

Reported by: Mike Taves Owned by: osgeo4w-dev@…
Priority: minor Component: Installer
Version: Keywords:
Cc:

Description

The Start menu group for OSGeo4W is starting to get disorganized. I have some desktop, shell and web apps installed on a few systems.

  • Quantum GIS is shown twice (I prefer the one without the version number)
  • The "OSGeo4 Shell" is nested within another OSGeo4W group
  • Apache controls would be very convenient from here (see #12). Also, I recall seeing an Apache control from the Task bar in MS4W, which I thought was convenient.

I'm not sure if some of the shortcuts are older and need to be flushed out, and rebuilt after each setup.

Attachments (1)

OSGeo4W_Start_menu.png (40.9 KB ) - added by Mike Taves 13 years ago.
OSGeo4W in the Start menu

Download all attachments as: .zip

Change History (6)

by Mike Taves, 13 years ago

Attachment: OSGeo4W_Start_menu.png added

OSGeo4W in the Start menu

in reply to:  description comment:1 by jef, 13 years ago

Replying to mwtoews:

  • Quantum GIS is shown twice (I prefer the one without the version number)

I'm not sure if some of the shortcuts are older and need to be flushed out, and rebuilt after each setup.

Right. I added a qgis-dev package that has a trunk build that can be install parallel to the stable qgis version. So I added "1.0" to the link and the other is labeled "(trunk)".

These are created by the postinstall script and are were to date never removed. I now added a preremove script to the qgis packages that removes the links from startmenu and desktop (and also fixed #48)

comment:2 by warmerdam, 13 years ago

I don't see the OSGeo4W shell nested under an OSGeo4W group within the OSGeo4W start menu. Perhaps this is an old artifact? We don't ever clean items from the start menu when uninstalling currently, but perhaps you could manually remove all the start menu items, and the installed OSGeo4W tree and then reinstall to see if the problem occurs again?

I thought we did have an apache install/restart/uninstall at one point, but I don't see it on mine. Assefa?

comment:3 by assefa, 13 years ago

Just checked and the short cut creations does not seem to be in the postinstall file. The apache start/install/uninstall bat files are there though. I will upload a new package with that does create the shortcuts. Note that there was an open bug on this: http://trac.osgeo.org/osgeo4w/ticket/12

in reply to:  2 comment:4 by Mike Taves, 13 years ago

Replying to warmerdam:

but perhaps you could manually remove all the start menu items, and the installed OSGeo4W tree and then reinstall to see if the problem occurs again?

I did this, and it did "clean" it up by removing the second QGIS shortcut, but I still see the double nesting "OSGeo4W > OSGeo4W > OSGeo4W Shell" as shown in the original attachment.


I thought we did have an apache install/restart/uninstall at one point, but I don't see it on mine.

In OSGeo4W/bin, I see: apache-install.bat apache-restart.bat apache-uninstall.bat

Maybe the Shell PATH should also include OSGeo4W/apache/bin for the other Apache related programs from the CMD/msys shells?

Also, I found the handy task bar control at OSGeo4W/apache/bin/ApacheMonitor.exe which I think is a good candidate EXE to add to the Start menu.

Finally, it would make sense to group all Apache related programs into it's own group: Start > OSGeo4W > Apache

comment:5 by jef, 14 months ago

Resolution: outdated
Status: newclosed
Note: See TracTickets for help on using tickets.