Opened 8 years ago

Closed 8 years ago

#426 closed defect (duplicate)

g.proj: projection can't be determined (64bit)

Reported by: hellik Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: GRASS, 64bit
Cc:

Description

from the ML:

http://lists.osgeo.org/pipermail/osgeo4w-dev/2014-July/002764.html

>> warning: projection can't be determined
>> modul can't be executed
>> command C:/OSGEO~1/apps/qgis/./grass/modules/qgis.g.info info=proj
>> <br><br> 
>> any idea?
>
>Not really.  I can open the gtopo30 map from the qgis_sample_data set just
>fine.

ok, it seems the underlying problem is in a broken OSGeo4W-GRASS6.4.3-5
64bit. 

I can start a GRASS session only in text mode because g.proj (and some other
modules, e.g. g.region, g.setproj) seems to be broken in
OSGeo4W-GRASS6.4.3-5 64 bit.

in a GRASS session in text mode I can start the module GUI e.g. by

GRASS 6.4.3 (nc_spm_08)> g.mlist --ui

or get the manual by

GRASS 6.4.3 (nc_spm_08)> g.mlist --help

Beschreibung:
 Liste vorhandene GRASS Datenbank-Dateien eines vom Nutzer bestimmten
Datentyps
und verwende optional ein Suchmuster.

Schlüsselwörter:
 Allgemein, Kartenverwaltung

but I can not do this for g.proj, g.region, g.setproj; therefore the QGIS
error:

>> command C:/OSGEO~1/apps/qgis/./grass/modules/qgis.g.info info=proj
>> <br><br>

as the underlying GRASS module isn't working correctly.

tested on 2 different win boxes.

Change History (5)

comment:1 Changed 8 years ago by hellik

Summary: OSGeo4W-64bit: qgis 2.4 - GRASS data can't be loadedOSGeo4W-64bit: qgis 2.4 - GRASS 6.4.3-5 broken

comment:2 Changed 8 years ago by hellik

Summary: OSGeo4W-64bit: qgis 2.4 - GRASS 6.4.3-5 brokenOSGeo4W-64bit: GRASS 6.4.3-5 broken

comment:3 Changed 8 years ago by jef

Keywords: 64bit added
Summary: OSGeo4W-64bit: GRASS 6.4.3-5 brokeng.proj: projection can't be determined (64bit)

comment:4 in reply to:  3 Changed 8 years ago by hellik

Replying to jef:

it's the same issue as in #420.

G.PROJ.EXE references to GDAL110.DLL which references to ICONV.DLL which references to KERNEL32.DLL and MSVCR80.DLL, but MSVCR80.DLL is missing

comment:5 Changed 8 years ago by jef

Resolution: duplicate
Status: newclosed

ok, so it's also a duplicate of #426.

Note: See TracTickets for help on using tickets.