Opened 5 years ago

Closed 21 months ago

#351 closed defect (fixed)

Using -a for Advanced selects two options (command line install)

Reported by: saultdon Owned by: jef
Priority: blocker Component: Installer
Version: 1.0 Keywords:
Cc:

Description

I'm using -a for Advanced on the command line installation, the whole thing looks like this:

osgeo4w-setup.exe -a -R C:\GIS\Programs\OSGeo4W -l W:\GIS\Programs\osgeo4w

But when the program starts, it actually has two options selected - Express Web-GIS Install and Advanced Install. Clicking Next closes the installer.

If I manually click Advanced Install and then Next, it works.

Attachments (1)

advanced_nothappening.png (20.1 KB) - added by saultdon 5 years ago.
Showing the two options selected after specifying "Advanced" only from the command line.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by saultdon

Attachment: advanced_nothappening.png added

Showing the two options selected after specifying "Advanced" only from the command line.

comment:1 Changed 4 years ago by saultdon

These still don't work with the latest 64bit installer.

comment:2 Changed 21 months ago by jef

Owner: changed from osgeo4w-dev@… to jef

comment:3 Changed 21 months ago by jef

Resolution: fixed
Status: newclosed

(In [1294]) * Resolve prerequisited in unattended mode (fixes #485)

  • Add -k/-autoaccept to automatically accept licenses in unattended mode and fix infinite loop in unattended mode (fixes #117, fixes #151, fixes #486)
  • Change short option for advanced mode from from a to A (fixes #351)
  • Change short option for disable-buggy-antivirus from A to b
  • Refactor out express_mode (fixes #262)
Note: See TracTickets for help on using tickets.