Opened 8 years ago

Closed 8 years ago

#339 closed defect (fixed)

OSGEO4W Installer doesn't work

Reported by: moreno Owned by: osgeo4w-dev@…
Priority: blocker Component: Installer
Version: Keywords: Installer OSGEO4W
Cc:

Description

The Installer OSGEO4W (http://download.osgeo.org/osgeo4w/osgeo4w-setup.exe) doesn't download the setup file (Windows XP/7)

Change History (11)

comment:1 in reply to:  description Changed 8 years ago by hellik

Replying to moreno:

The Installer OSGEO4W (http://download.osgeo.org/osgeo4w/osgeo4w-setup.exe) doesn't download the setup file (Windows XP/7)

confirmed. it seems to be setup: OSGeo4W Installer/Setup? version 1.0.6-8.

error message: "mount: access denied".

Helmut

comment:2 Changed 8 years ago by maphew

hmm. Works for me this morning. How did you retrieve the version #? I don't see it. ‎The one I downloaded this morning has a creation date of "2011 ‎March ‎02, ‏‎7:33:07 AM".

Possible difference between mine and yours: I have UAC turned off. Try running setup with elevated admin privileges (r-click >> Run as Administrator). If it still doesn't work and your need is immediate you might try pkg-apt/AptFromScratch.

comment:3 Changed 8 years ago by maphew

argh. got the wiki link syntac wrong and can't edit the message; that should have been http://trac.osgeo.org/osgeo4w/wiki/pkg-apt/AptFromScratch

comment:4 in reply to:  2 ; Changed 8 years ago by hellik

Replying to maphew:

hmm. Works for me this morning. How did you retrieve the version #? I don't see it. ‎The one I downloaded this morning has a creation date of "2011 ‎March ‎02, ‏‎7:33:07 AM".

OSGeo4W installed some time ago.

today morning:

All Programms -> OSGeo4W -> Setup -> Advanced Install => there is an updated OSGeo4W Installer/Setup? available

Possible difference between mine and yours: I have UAC turned off. Try running setup with elevated admin privileges (r-click >> Run as Administrator).

admin rights are elevated, this isn't the problem here.

could it be that accessing http://download.osgeo.org/osgeo4w/setup.ini is causing this issue?

comment:5 in reply to:  4 Changed 8 years ago by hellik

Replying to hellik:

could it be that accessing http://download.osgeo.org/osgeo4w/setup.ini is causing this issue?

more precisely that All Programms -> OSGeo4W -> Setup -> Advanced Install can't access http://download.osgeo.org/osgeo4w/setup.ini?

but I can browse http://download.osgeo.org/osgeo4w/setup.ini with firefox.

comment:6 in reply to:  4 Changed 8 years ago by hellik

Replying to hellik:

Possible difference between mine and yours: I have UAC turned off. Try running setup with elevated admin privileges (r-click >> Run as Administrator).

admin rights are elevated, this isn't the problem here.

ah...there seems to be a UAC-behaviour change by windows os itself (?)...

sorry for the noise, it works now here on my side.

thanks Helmut

comment:7 Changed 8 years ago by warmerdam

Helmut,

What did you have to do to fix this? It seems like it might be related to a problem I'm running into on one system.

comment:8 in reply to:  7 Changed 8 years ago by hellik

Frank

Replying to warmerdam:

What did you have to do to fix this? It seems like it might be related to a problem I'm running into on one system.

AFAIR All Programms -> OSGeo4W -> Setup called automatically elevated admin privileges which I had to confirm.

now with the OSGeo4W Installer/Setup? version 1.0.6-8 (visible in the Advanced Install), I have to do r-click >> Run as Administrator. no idea at the moment why this behaviour change.

HTH Helmut

comment:9 Changed 8 years ago by lpinner

Non-elevated behaviour is a result of this ticket -http://trac.osgeo.org/osgeo4w/ticket/304 which likely causes permissions issues when not run as Admin on an existing OSGeo4W install where all files would require Admin privileges to modify.

comment:10 in reply to:  9 Changed 8 years ago by hellik

Replying to lpinner:

Non-elevated behaviour is a result of this ticket -http://trac.osgeo.org/osgeo4w/ticket/304 which likely causes permissions issues when not run as Admin on an existing OSGeo4W install where all files would require Admin privileges to modify.

thanks for the hint.

I suggest some short note about this somewhere in website/wiki/trac and then to close the ticket.

comment:11 Changed 8 years ago by moreno

Resolution: fixed
Status: newclosed

Now it's working.

Note: See TracTickets for help on using tickets.