Opened 8 years ago

Closed 8 years ago

#313 closed defect (fixed)

gdal-mrsid crashes now with GDAL 1.9.2 package

Reported by: warmerdam Owned by: warmerdam
Priority: major Component: Package
Version: Keywords: mrsid gdal
Cc:

Description

gdal-mrsid crashes now with GDAL 1.9.2 package

Appears to relate to the 1.9.2 upgrade.

Change History (5)

comment:1 Changed 8 years ago by warmerdam

Status: newassigned

I have confirmed the problem is with GDAL 1.9.2 as uploaded and goes away with previous GDAL build.

I believe it is due to the upgrade in version of MSVC used. I'm going to look into rebuilding the mrsid plugin with the new msvc (visual studio 2010 I believe). The ECW and Oracle plugin packages are also seemingly affected (confirmed at least with oracle)

comment:2 Changed 8 years ago by jef

gdal-oracle was meanwhile updated.

comment:3 in reply to:  1 Changed 8 years ago by custard

Replying to warmerdam:

The ECW and Oracle plugin packages are also seemingly affected (confirmed at least with oracle)

I'll confirm gdal-ecw affected as well.

comment:4 Changed 8 years ago by warmerdam

gdal-mrsid 1.9.2-0 package uploaded and should fix this for the MrSID plugin.

Please test.

comment:5 Changed 8 years ago by warmerdam

Resolution: fixed
Status: assignedclosed

Apparently working fine.

Note: See TracTickets for help on using tickets.