Opened 10 years ago

Closed 14 months ago

#307 closed defect (outdated)

OpenEV does not start because of Python error

Reported by: jratike80 Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: OpenEV
Cc:

Description

Hi,

I installed OpenEV with the OSGeo4W installer today but it does not start. The error is

C:\OSGeo4w\bin>openev.bat

_path=C:\OSGeo4w\apps\Python27\Scripts
OSGEO4W home is C:\OSGeo4w
Traceback (most recent call last):
  File "C:\OSGeo4w\apps\openev\pymod\openev.py", line 80, in <module>
    import gviewapp
  File "C:\OSGeo4w\apps\openev\pymod\gviewapp.py", line 136, in <module>
    import gtk
  File "C:\OSGeo4w\apps\openev\pymod\gtk.py", line 844
    def set_policy(self, as, ag, autos):
                          ^
SyntaxError: invalid syntax

Change History (3)

comment:1 by warmerdam, 10 years ago

Resolution: wontfix
Status: newclosed

I see the same problem, but only if I run openev.bat within C:\OSGeo4W\bin. If I run it somewhere else, I get proper behavior. I believe that is because if you run it from within the bin directory the local DLLs take precidence over other special version DLLs required by OpenEV. I don't forsee an easy way to fix this.

On that basis I'm going to tentatively close this ticket, but I'm open to suggestions.

comment:2 by jratike80, 10 years ago

Resolution: wontfix
Status: closedreopened

Well, perhaps the main problem is then that OSGeo4W installer creates me a shortcut that looks like this

"C:\Windows\system32\ " C:\OSGeo4w\bin\openev.bat

Because the shortcut did not work I tried to run the batch file directly with the result I reported earlier

comment:3 by jef, 14 months ago

Resolution: outdated
Status: reopenedclosed
Note: See TracTickets for help on using tickets.