Opened 14 years ago

Closed 8 years ago

#27 closed defect (fixed)

Package gdaI-dev: ippj-5.3.dll not found

Reported by: klokan Owned by: warmerdam
Priority: major Component: Installer
Version: Keywords: ipp
Cc:

Description

I realized on some computers there is a problem with gdal-dev package. Some testers installed OSGeo4W and gdal-dev according my instructions at http://help.maptiler.org/betatest. After they run the command 'gdaldev' they receive for any gdal command an error message:

"This application has failed to start because ippj-5.3.dll was not found, re-installing the application may fix this problem."

Such error appears in both Windows XP SP2 and Vista on some computers. On my machines it did not appear.

Probably because it was linked against Intel Integrated Performance Primitives? Maybe the error appears only on computers with non-Intel processors - like AMD? I will ask the testers.

There are three people already reporting this error, and they are willing to test and help with solving this trouble....

More info: http://groups.google.com/group/maptiler/browse_thread/thread/6bfb0f60c93df151 http://code.google.com/p/maptiler/issues/detail?id=1

--

Discussed on osgeo4w-dev: http://lists.osgeo.org/pipermail/osgeo4w-dev/2008-November/000254.html

Change History (10)

comment:1 by klokan, 14 years ago

FrankW and Klokan discussion from OSGeo4W-dev:

Is there any chance these folks might have installed the libjpeg-ipp package?

I think they selected only the gdal-dev package and other dependent packages were installed automatically.

Isn't there some kind of detection for selecting IPP version of libjpeg as dependency? What should they try to run to help you to localize the problem?

I am just man in the middle as I did not succeed to reproduce the error on my computer unfortunately.

The intention is that this optional package is the only one that should depend on having the IPP primatives preinstalled. The default libjpeg package should not depend on IPP.

Is not it possible that there is dependency also somewhere else?

comment:2 by warmerdam, 14 years ago

Keywords: ipp added
Owner: changed from osgeo4w-dev@… to warmerdam
Status: newassigned

Petr,

On one of my test systems I have uninstalled the IPP dlls, and done a clean install of only the "gdal-dev" package and it's dependencies. This did not appear to have any IPP dependencies. I think we need to bring one of the more savvy folks who is running into the problem into this ticket.

Most of all, I'd like them to confirm in the advance install interface that they do not have the libjpeg-ipp package installed.

comment:3 by gilligan, 14 years ago

I got it to work by:

  1. uninstalling all osgeo4w then
  2. running express install gdal only
  3. running advanced install and install gdal-dev 1.6pre-9

This was on a clean Vista machine.

comment:4 by klokan, 13 years ago

gilligan: This is not a good universal solution.

The solution should be: delete the directory C:\OSGeo4W, start installation again and follow _exactly_ the tutorial from http://help.maptiler.org/betatest/. You should select only the package 'gdal-dev', do not click on any other package. Then everything runs as it should...

FrankW: I think the problem is that people are selecting more packages in the Advanced installation and again unselecting them, which is keeping dependent libraries selected. Some people are confused from the installation... but I don't know how to help them more. Hopefully it will get better as soon as GDAL 1.6 will become stable.

comment:5 by warmerdam, 13 years ago

The only package that should exhibit problems like this is the libjpeg-ipp package, and there should not be any other package that depends on it.

Fixing the problem *should* be as simple as requesting a reinstall for the libjpeg package which will replace the jpeg_osgeo.dll with the non-IPP one.

If anyone can clearly establish broader problems please note it here for me to dig into further.

comment:6 by tomkralidis, 13 years ago

I had this issue exactly. Doing as Frank says (plus removing libjpeg-ipp), did the trick.

comment:7 by springmeyer, 12 years ago

Just hit this exact issue down in Haiti, when assisting a mapping team that had a broken version of QGIS. Finding and re-installing libjpeg fixed it. Not sure how it originally happened. This machine specs were:

Intel(R) Core(TM)2 Duo CPU
E7500 @ 2.93GHz
Physical Address Extension

Windows XP professions Version 2002 Service Pack 3

Had installed via OSGEO4W only:

msys, QGIS 1.0, 1.4, 1.5, udig, openev, grassgis

comment:8 by warmerdam, 9 years ago

Resolution: wontfix
Status: assignedclosed

gdal-dev package removed, ticket no longer relavent.

in reply to:  8 ; comment:9 by jvdmdoacpro, 8 years ago

Component: DocumentationInstaller
Resolution: wontfix
Status: closedreopened

Replying to warmerdam:

gdal-dev package removed, ticket no longer relavent.

Dell Inspiron 5110N with Intel i7-2630QM (2.0 GHz) Widows 7

Using "osgeo4w-setup-x86.exe" to install from internet (Grass 6.4.3)

Installed "Advanced Install" with only non-web based installation - Have problem with running at */etc/postinstall/qgis-common.bat - some python problem.

Uninstalled everything

Installed "Advanced Install" with ALL options - Have problem with some sub-programme complaining about ippj-5.3.dll already during install as well as when invoking qgis.bat

This ticket is OLD, but apparently became alive again!.

Now how is it possible that something that has been removed, remain causing problems?

It is either there or not - cannot be both.

I had a perfectly good 6.4.0 working - after "upgrading" to 6.4.3 all hell broke loose. None of the suggestions on any of the forums is resolving anything. Only managed to get latest SAGA going through its own installer.

Reinstallation reports on postinstall (umpteenth time)

Package: ka-map

ka-map.bat exit code 1

Package: qgis-common

qgis-common.bat exit code -1073741515

Package: qgis-dev

qgis-dev.bat exit code -1073741515

Should I scrap the entire computer for a new one perhaps?

in reply to:  9 comment:10 by jef, 8 years ago

Resolution: fixed
Status: reopenedclosed

Replying to jvdmdoacpro:

Installed "Advanced Install" with ALL options - Have problem with some sub-programme complaining about ippj-5.3.dll already during install as well as when invoking qgis.bat

Calm down please. Why did you install ALL packages? No need.

Anyway, that means you installed voluntarily installed libjpeg-ipp although nothing depends on it anymore (gdal-dev appearenty used to). But you missed to install the third party stuff that it depends on and therefore everything depending on libjpeg went defunct (see pkg-libjpeg-ipp). Either install the missing dependencies or remove libjpeg-ipp and reinstall libjpeg-6b.

Note: See TracTickets for help on using tickets.