multiple GDAL versions used
|Reported by:||msieczka||Owned by:|
I have just installed QGIS 1.6.0 via Express Install and in QGIS's Help > About I found out that it was built against GDAL 1.5.4 (released nearly 2 years ago).
Would there be any problem to build QGIS against recently released GDAL 1.7.3?
According to "%OSGEO4W_ROOT%"\bin\qgis.bat and Dependency Walker, it is run against 1.7.3 anyway. Also GdalTools QGIS plugin, enabled by default, depends on 1.7.3.
BTW: could such mismatches between runtime and buildtime GDAL versions pose issues?
GDAL 1.5.4 is still installed only as gpsbabel and OpenEV dependency AFAICT, and GDAL 1.6.3 as GRASS 6.4.0 dependency. Why isn't GDAL 1.7.3 used everywhere instead?
Current situation is puzzling and makes it harder to debug issues related to GDAL.
Change History (10)
follow-ups: 4 5 comment:3 by , 12 years ago
|Priority:||major → trivial|
|Status:||reopened → closed|