Opened 14 years ago

Closed 11 years ago

#370 closed task (fixed)

Incubator Application: rasdaman

Reported by: warmerdam Owned by: warmerdam
Priority: major Milestone:
Component: Incubator Keywords: application
Cc: pebau

Description (last modified by warmerdam)

  1. Please provide the name and email address of the principal Project Owner.‭

Peter Baumann (p.baumann at jacobs-university dot de)

  1. Please provide the names and emails of co-project owners‭ (‬if any‭)‬.

none

  1. Please provide the names,‭ ‬emails and entity affiliation of all official committers.

For the moment being:‭ ‬Peter Baumann,‭ ‬see above.

  1. Please describe your Project.

Rasdaman (raster data manager) is an array database system (also called raster database system). It allows to retrieve and maintain multi-dimensional arrays of unlimited size stored in standard relational databases through an SQL-style query language.

The information category "array" appears - as sensor, image, or statistics data - in manifold applications, such as earth sciences, space sciences, life sciences, engineering, and multimedia.

Rasdaman allows to quickly set up array-intensive services which are distinguished by their speed, flexibility, and scalability. In conjunction with the free PetaScope package (www.petascope.org), rasdaman represents an outstandingly powerful, flexible, and scalable geo raster server.

  1. Why is hosting at OSGeo good for your project‭?

OSGeo gives particular visibility among the target user community,‭ ‬earth science data providers as well as institutional‭ ‬/‭ ‬commercial geo data providers.

  1. What type of application does this project represent(client,‭ ‬server,‭ ‬standalone,‭ ‬library,‭ ‬etc.‭)‬:‭

server,‭ ‬based on the PostgreSQL DBMS,‭ ‬along with C++‭ ‬and Java client APIs

  1. Please describe any relationships to other open source projects.‭

Rasdaman uses PostgreSQL the PetaScope project‭ (‬to be released in June‭ ‬2009‭) ‬uses rasdaman.

  1. Please describe any relationships with commercial companies or products

The open source rasdaman version,‭ ‬named‭ ‬rasdaman community,‭ ‬is augmented by‭ ‬rasdaman enterprise,‭ ‬a commercial variant marketed by the research spin-off rasdaman GmbH‭ (‬); this variant offers additional performance boosters and tools.‭ ‬Said company also offers support for both variants.

  1. Which open source license(s‭) ‬will the source code be released under‭?

GPL v3 See http://maitai.eecs.jacobs-university.de:8000/trac/rasdaman/browser/LICENSE

  1. Is there already a beta or official release‭?

Yes,‭ ‬available for download from‭ ‬ www.rasdaman.org

  1. What is the origin of your project‭ (‬commercial,‭ ‬experimental,‭ ‬thesis or other higher education,‭ ‬government,‭ ‬or some other source‭)?

originally,‭ ‬research funded through several EU projects.‭ ‬Then commercialized by the research spin-off,‭ ‬rasdaman GmbH.‭

  1. Does the project support open standards‭? ‬Which ones and to what extent‭? (‬OGC,‭ ‬w3c,‭ ‬ect.‭) ‬Has the software been certified to any standard‭ (‬CITE for example‭)? ‬If not,‭ ‬is it the intention of the project owners to seek certification at some point‭?

Rasdaman per se is application domain agonstic and supports multi-dimensional arrays as such.‭ ‬The soon-to-come PetaScope package adds OGC-based interfaces,‭ ‬in particular:‭ ‬WCS,‭ ‬WCS-T,‭ ‬WCPS.‭ ‬As a parallel research activity,‭ ‬a CITE test suite is under development.

  1. Is the code free of patents,‭ ‬trademarks,‭ ‬and do you control the copyright‭?

Copyright for the commercial version is with Peter Baumann‭ ‬/‭ ‬rasdaman GmbH.‭ ‬The free version also is copyright by Jacobs University.‭ ‬Peter Baumann holds patents on the rasdaman architecture.‭ ‬All contributors have to agree to the Rasdaman License Agreement which,‭ ‬following the usual open source style,‭ ‬grants appropriate rights on the contribution to the rasdaman project.

  1. How many people actively contribute‭ (‬code,‭ ‬documentation,‭ ‬other‭?) ‬to the project at this time‭?

Currently‭ ‬12‭ ‬developers.

  1. How many people have commit access to the source code respository‭?

Currently‭ ‬1‭ ‬because the automated regression test suite is not yet operational.‭ ‬As soon as this will be available,‭ ‬access will be opened further.

  1. Approximately how many users are currently using this project‭?

say,‭ ‬10‭ ‬institutions.‭ ‬Among then the French National Geographic Institute and Vattenfall Europe Mining AG.

  1. What type of users does your project attract‭ (‬government,‭ ‬commercial,‭ ‬hobby,‭ ‬academic research,‭ ‬etc.‭ )?

research,‭ ‬government‭ (‬for extending SDIs with fast,‭ ‬flexible raster services‭)‬,‭ ‬commercial‭ (‬for running own data services or as part of project offerings‭)

  1. If you do not intend to host any portion of this project using the OSGeo infrastructure,‭ ‬why should you be considered a member project of the OSGeo Foundation‭?

We now have to decide where to host our mailing lists,‭ ‬and if this can be decided quickly we would prefer to host them at OSGeo.‭ ‬The web site as such is up and running,‭ ‬and we will link appropriately with OSGeo.

  1. Does the project include an automated build and test‭?

automatic build:‭ ‬yes,‭ ‬automatic test:‭ ‬not yet.

  1. What language(s‭) ‬are used in this project‭? (‬C/Java/perl/etc‭)

C++‭ (‬server and client‭)‬,‭ ‬Java‭ (‬client‭)

  1. What is the dominant written language‭ (‬i.e.‭ ‬English,‭ ‬French,‭ ‬Spanish,‭ ‬German,‭ ‬etc‭) ‬of the core developers‭?

english

  1. What is the‭ (‬estimated‭) ‬size of a full release of this project‭? ‬How many users do you expect to download the project when it is released‭?

the complete tarball has about‭ ‬1.5‭ ‬MB. How many users‭? ‬We have no idea...

Change History (9)

comment:1 by pebau, 14 years ago

here a complete version of the answer to Q15:

Rasdaman (raster data manager) is an array database system (also called raster database system). It allows to retrieve and maintain multi-dimensional arrays of unlimited size stored in standard relational databases through an SQL-style query language.

The information category "array" appears - as sensor, image, or statistics data - in manifold applications, such as earth sciences, space sciences, life sciences, engineering, and multimedia.

Rasdaman allows to quickly set up array-intensive services which are distinguished by their speed, flexibility, and scalability. In conjunction with the free PetaScope package (www.petascope.org), rasdaman represents an outstandingly powerful, flexible, and scalable geo raster server.

in reply to:  1 comment:2 by pebau, 14 years ago

Replying to pebau:

here a complete version of the answer to Q15:

sorry, it's Q4.

Rasdaman (raster data manager) is an array database system (also called raster database system). It allows to retrieve and maintain multi-dimensional arrays of unlimited size stored in standard relational databases through an SQL-style query language.

The information category "array" appears - as sensor, image, or statistics data - in manifold applications, such as earth sciences, space sciences, life sciences, engineering, and multimedia.

Rasdaman allows to quickly set up array-intensive services which are distinguished by their speed, flexibility, and scalability. In conjunction with the free PetaScope package (www.petascope.org), rasdaman represents an outstandingly powerful, flexible, and scalable geo raster server.

comment:3 by pramsey, 14 years ago

I see mention of both "Rasdaman License Agreement" and GPL. What is the relationship between the two?

in reply to:  3 comment:4 by pebau, 14 years ago

Replying to pramsey:

I see mention of both "Rasdaman License Agreement" and GPL. What is the relationship between the two?

That was a misleading phrasing of mine. The license model is GPL, and contributors have to co-submit a Rasdaman _Contributor_ (not License) Agreement, available from http://maitai.eecs.jacobs-university.de:8000/trac/rasdaman/patchmanager.

comment:6 by warmerdam, 14 years ago

Cc: pebau added
Description: modified (diff)

Incorporate a couple suggested changes into the application.

comment:7 by pebau, 12 years ago

Priority: normalmajor

FYI, rasdaman has submitted a path to GDAL adding a driver which allows GDAL to read from rasdaman.

BTW, at an age of 16 months: what is the status - has Bruce Bannerman be confirmed by OSGeo to be our mentor? Are we already in incubation status? What are the next steps to be taken?

thanks, Peter

comment:8 by pebau, 11 years ago

Hm, anybody out there? Now it is 2 years, and I am still looking forward to understanding the order of incubation progress and how it's documented. Maybe OSGeo is implicitly bypassing projects with a dual-license model? Thanks for any clarification, Peter

comment:9 by jive, 11 years ago

Resolution: fixed
Status: newclosed

Okay as per Incomm Meeting 15 Bruce Bannerman has volunteered to mentor. Marking this one as closed.

Note: See TracTickets for help on using tickets.