Opened 12 years ago

Closed 5 years ago

#355 closed task (wontfix)

Enable themes in Trac

Reported by: timlinux Owned by: sac@…
Priority: normal Milestone: Unplanned
Component: Trac Keywords: trac theme
Cc: otto.dassau@…

Description

We are in the process of unifying the look and feel of all QGIS web assets - website, wiki, blog, trac, etc.

I would like to install the trac theme manager extension and a customised version of the crystalx theme. I am happy to do the work myself or if someone on the admin side can do it that would be great too.

The installation will require restart of apache.

I have tested the procedure on a local machine here and the procedure is as follows:

First install python-dev headers which is going to be needed by some of the theme engine deps.

sudo apt-get install python2.5-dev

The equivalent package under fedora will need to be installed for the above step.

Next get the theme engine from here:

http://trac-hacks.org/wiki/ThemeEnginePlugin

Look for the "Download and Source" section on the above page.

Now unzip the zip and cd into its 0.11 dir then do:

sudo python setup.py install

Next get the crystal theme from here:

http://trac-hacks.org/wiki/CrystalxTheme

Download the theme and extract it then do:

cd crystalxtheme/0.11/
sudo python setup.py install

Finally add to the trac ini a couple of lines:

vim /opt/trac/sac/conf/trac.ini

# Added by Tim for crystal theme support
[components]
themeengine.* = enabled
crystalxtheme.* = enabled

[theme]
theme = CrystalX

After doing these steps go into trac admin and enble the themeengine and crystal theme plugins.

Note We will use a customised version of the above theme.

Are there any objections to me going ahead and installing this? If not can you provide me the appropriate details for connecting to the trac server?

Change History (9)

comment:1 Changed 12 years ago by timlinux

Further to this I chatted to Frank W. on IRC last night. He would prefer that hobu carry our the needed installations. I will attach our customised version of crystalx theme to this ticket over the next day or two. Please standby for that.

Many thanks

Tim

comment:2 Changed 12 years ago by hobu

A few problems.

1) We run Python 2.3 on a rather ancient system 2) We're running Trac 0.10.1, and theming requires at least 0.11.x IIRC 3) We only allow "Primary Admins" root access on the OSGeo server to do stuff like this. The process to being a Primary Admin isn't onerous, but it will involve more than fixing your one or two pet issues :)

See #365 for more information on what we plan to do to get to 0.11

comment:3 Changed 12 years ago by timlinux

Hi

Since I posted this ticket I tried to use the above mentioned theme in a production environment. However it is fixed width which caused quite a few problems with poorly laid out reports etc.

There are other themes e.g. GnomeBR that are not fixed width, and some themes that are available for 10.x too. That said I am happy to wait if you have a migration plan to 0.11, which will give us some time to get a more appropriate theme prepared.

Many thanks

Tim

comment:4 Changed 11 years ago by crschmidt

Milestone: Unplanned

Tim confirmed in IRC that he doesn't currently have a theme to install here that he wants to use; for the time being, I'm moving this to Unplanned, until we get feedback from Tim that he's ready to proceed here.

comment:5 Changed 6 years ago by strk

Tim, I guess you don't really need this anymore ? QGIS code now is on github (also unbranded)

comment:6 Changed 6 years ago by jef

We use our (branded) redmine for bugtracking. Only git is hosted on github.

comment:7 Changed 6 years ago by strk

Jef: so do you confirm you don't need trac themes or are you planning to move from redmine to trac ?

comment:8 Changed 6 years ago by strk

I'd close this for lack of feedback

comment:9 Changed 5 years ago by strk

Component: Systems AdminTrac
Resolution: wontfix
Status: newclosed

closing for lack of feedback

Note: See TracTickets for help on using tickets.