Opened 11 months ago

Closed 9 months ago

#2941 closed defect (fixed)

Wiki login gives Internal error

Reported by: Schpidi Owned by: sac@…
Priority: normal Milestone: Sysadmin Contract 2023-I
Component: SysAdmin Keywords:
Cc:

Description

Logging in with my user Schpidi results in this error:

Internal error
Jump to navigationJump to search
[c1d2f6717e34a599ea7267f6] /w/index.php?title=Special:LDAPUserMerge&returnto=Main_Page Error from line 536 of /var/www/wiki_osgeo/html/w/includes/htmlform/HTMLForm.php: Class 'htmlbuttonfield' not found

Backtrace:

#0 /var/www/wiki_osgeo/html/w/includes/htmlform/OOUIHTMLForm.php(51): HTMLForm::loadInputFromParameters()
#1 /var/www/wiki_osgeo/html/w/includes/htmlform/HTMLForm.php(385): OOUIHTMLForm::loadInputFromParameters()
#2 /var/www/wiki_osgeo/html/w/includes/htmlform/HTMLForm.php(362): HTMLForm->addFields()
#3 /var/www/wiki_osgeo/html/w/includes/htmlform/OOUIHTMLForm.php(37): HTMLForm->__construct()
#4 /var/www/wiki_osgeo/html/w/includes/htmlform/HTMLForm.php(320): OOUIHTMLForm->__construct()
#5 /var/www/wiki_osgeo/html/w/includes/specialpage/FormSpecialPage.php(120): HTMLForm::factory()
#6 /var/www/wiki_osgeo/html/w/includes/specialpage/FormSpecialPage.php(186): FormSpecialPage->getForm()
#7 /var/www/wiki_osgeo/html/w/extensions/WikiToLDAP/includes/SpecialLDAPMerge.php(115): FormSpecialPage->execute()
#8 /var/www/wiki_osgeo/html/w/includes/specialpage/SpecialPage.php(600): MediaWiki\Extension\WikiToLDAP\SpecialLDAPMerge->execute()
#9 /var/www/wiki_osgeo/html/w/includes/specialpage/SpecialPageFactory.php(635): SpecialPage->run()
#10 /var/www/wiki_osgeo/html/w/includes/MediaWiki.php(307): MediaWiki\SpecialPage\SpecialPageFactory->executePath()
#11 /var/www/wiki_osgeo/html/w/includes/MediaWiki.php(947): MediaWiki->performRequest()
#12 /var/www/wiki_osgeo/html/w/includes/MediaWiki.php(547): MediaWiki->main()
#13 /var/www/wiki_osgeo/html/w/index.php(53): MediaWiki->run()
#14 /var/www/wiki_osgeo/html/w/index.php(46): wfIndexMain()
#15 {main}

Thanks for any help!

Change History (7)

comment:1 by lnicola, 11 months ago

Hi, can you try again?

in reply to:  1 comment:2 by Schpidi, 11 months ago

Replying to lnicola:

Hi, can you try again?

Awesome, it is working now. Many thanks.

comment:3 by lnicola, 11 months ago

Resolution: fixed
Status: newclosed

comment:4 by fschindler, 9 months ago

Resolution: fixed
Status: closedreopened

I'm having exactly the same issue now (User fschindler), maybe this is more systematic?

comment:5 by robe, 9 months ago

Milestone: UnplannedSysadmin Contract 2023-I

comment:6 by robe, 9 months ago

I think I finally figured out the issue. I think it was just a casing one.

fix here - https://git.osgeo.org/gitea/hexmode/WikiToLDAP/pulls/15

diff --git a/includes/SpecialLDAPMerge.php b/includes/SpecialLDAPMerge.php
index 79d254f..ad617e8 100644
--- a/includes/SpecialLDAPMerge.php
+++ b/includes/SpecialLDAPMerge.php
@@ -228,7 +228,7 @@ class SpecialLDAPMerge extends FormSpecialPage {
 				"default" => new Message( $this->getMessagePrefix() . "-ldap-introduction" )
 			],
 			"cancel" => [
-				"class" => "htmlbuttonfield",
+				"class" => "HTMLButtonField",
 				"id" => $this->getMessagePrefix() . "-ldap-cancel",
 				"buttonlabel-message" => $this->getMessagePrefix() . "-ldap-cancel",
 				"formnovalidate" => true

I'll close once I've confirmed this is the right fix and try to push this upstream.

We still have the annoying issue that for new users when they log in, even if no wiki account, it prompts for them to merge. I'm thinking at this point everyone that wanted to merge has done so. So best course of action, is to just disable merging. But hitting "Skip" in my tests does seem to do the right thing and have the user in the merged account group.

comment:7 by robe, 9 months ago

Resolution: fixed
Status: reopenedclosed

Seems to be working. I don't see any new people showing in the "In progress list" recently and got a confirmation from one new registrant that he was able to login fine.

Note: See TracTickets for help on using tickets.