Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#2678 closed task (fixed)

old-adhoc planned shutdown

Reported by: robe Owned by: sac@…
Priority: normal Milestone: Sysadmin Contract 2022-II
Component: SysAdmin Keywords:
Cc:

Description

I think most things have been moved off of old-adhoc. Given it's age, I'd like to just shut it down or at very least turn off the apache service before the beginning of the new year

Things that have already been moved off it are:

demo.mapserver.org
demo.pycsw.org

Things that are still running

#when I check this it's actually running on 208.218.69.159.clients.your-server.de (159.69.218.208) - so I shut it off
demo.geohealthcheck.org
demo.pywps.org #looks like this was never resetup as not reachable from outside (so I shut it off), I suspect it should live with demo.pycsw.org which has a nice dedicated new pycsw or similar container setup

#I shut down
dev.geohealtcheck.org #no dns so shut down

This I left, but I suspect it is an orphaned sites

oam.osgeo.org (I suspect this is an abandoned site)

Change History (26)

comment:1 by strk, 2 years ago

Milestone: Sysadmin Contract 2021-IISysadmin Contract 2022-I

Ticket retargeted after milestone closed

comment:2 by robe, 2 years ago

Milestone: Sysadmin Contract 2022-ISysadmin Contract 2022-II
Resolution: fixed
Status: newclosed

Done

comment:3 by robe, 2 years ago

Steps involved:

shutdown old-adhoc container Remove from /etc/nginx/sites-enabled the adhoc.osgeo.org config.

Note on wiki - https://wiki.osgeo.org/wiki/AdhocVM and https://wiki.osgeo.org/wiki/SAC_Service_Status#old-adhoc

comment:4 by strk, 2 years ago

It looks like there was a left-over entry in nginx: #2714

comment:5 by strk, 2 years ago

Was the demo.mapserver.org service moved elsewhere ?

in reply to:  5 comment:6 by Jeff McKenna, 2 years ago

Replying to strk:

Was the demo.mapserver.org service moved elsewhere ?

Yes, see https://wiki.osgeo.org/wiki/MapServer_at_osgeo7 (it was a ton of effort, but important)

comment:7 by strk, 2 years ago

The nginx configuration for demo.mapserver.org is STILL pointing at the old-adhoc VM - I had to run it again to make things work. Are you expecting it to instead point at the mapserver container Jeff ?

comment:8 by Jeff McKenna, 2 years ago

old.demo.mapserver.org should still point to old-adhoc VM yes. However since old-adhoc is now shutdown, the old.demo.mapserver.org alias can be removed.

comment:9 by strk, 2 years ago

Resolution: fixed
Status: closedreopened

comment:10 by strk, 2 years ago

The problem is that ALSO demo.mapserver.org is pointing at old-adhoc

comment:11 by Jeff McKenna, 2 years ago

demo.mapserver.org correctly points to the mapserver container; the issue that you found is that the "old.demo.mapserver.org" alias in nginx still points to adhoc, where in fact that old alias should now be removed from nginx settings. Hope this makes sense.

comment:12 by Jeff McKenna, 2 years ago

no it does not: the new services are live (from the osgeo7 mapserver container) at demo.mapserver.org

comment:13 by Jeff McKenna, 2 years ago

Regina helped me this the nginx settings, in another ticket. It is all working great. I am not sure what you see here.

comment:14 by strk, 2 years ago

For location /geocache nginx is still pointing at old-adhoc

comment:15 by strk, 2 years ago

Is that handling of /geocache to be removed ?

comment:16 by strk, 2 years ago

Jeff: as for "what I see here" this is what I see: I can NOT reload nginx if old-adhoc container is shutdown (as it was). The only way to reload the configuration (or restart nginx) was to bring old-adhoc back up

in reply to:  14 comment:17 by Jeff McKenna, 2 years ago

Replying to strk:

For location /geocache nginx is still pointing at old-adhoc

There is no more /geocache link, i spent a month of effort to setup MapCache for this. I documented all of this on the wiki page I mentioned.

in reply to:  16 comment:18 by Jeff McKenna, 2 years ago

Replying to strk:

Jeff: as for "what I see here" this is what I see: I can NOT reload nginx if old-adhoc container is shutdown (as it was). The only way to reload the configuration (or restart nginx) was to bring old-adhoc back up

Speaking honestly here, I am not seeing a reason to do that. Everything is working fine with the new container and demo.mapserver.org services

comment:19 by Jeff McKenna, 2 years ago

As documented on the wiki page, the new url for caching is https://demo.mapserver.org/mapcache/

(the /geocache settings you refer to are not used)

Last edited 2 years ago by Jeff McKenna (previous) (diff)

comment:20 by strk, 2 years ago

Ok so I removed the special handling of demo.mapserver.org/geocache AND the entry for old.demo.mapserver.org

Only left over nginx configurations pointing at old-adhoc is oam.osgeo.org -- such service currently points at old-adhoc, does anyone have an idea of who's in charge of managing it ?

in reply to:  20 comment:21 by Jeff McKenna, 2 years ago

Replying to strk:

Ok so I removed the special handling of demo.mapserver.org/geocache AND the entry for old.demo.mapserver.org

thanks

Only left over nginx configurations pointing at old-adhoc is oam.osgeo.org -- such service currently points at old-adhoc, does anyone have an idea of who's in charge of managing it ?

I have never heard of that before.

comment:22 by strk, 2 years ago

Well oam.osgeo.org is listed as "to be retired" in https://wiki.osgeo.org/wiki/AdhocVM so I'm going to remove that config as well

in reply to:  20 comment:23 by Jeff McKenna, 2 years ago

Replying to strk:

Only left over nginx configurations pointing at old-adhoc is oam.osgeo.org -- such service currently points at old-adhoc, does anyone have an idea of who's in charge of managing it ?

See the oam.osgeo.org note at https://wiki.osgeo.org/wiki/AdhocVM

It was OpenArialMap, by Chris Schmidt, and can be removed, as noted there.

comment:24 by strk, 2 years ago

Resolution: fixed
Status: reopenedclosed

Alright, oam.osgeo.org disabled and adhoc stopped again

comment:25 by hamish, 2 years ago

For whatever it's worth, I had a GRASS demo running on adhoc as a cron job (plotting daily global earthquakes from USGS data), but nothing depended on it so no worries.

Hamish

comment:26 by robe, 2 years ago

Hamish,

If you want to still keep that we can put in on a different container. Let us know.

Note: See TracTickets for help on using tickets.