Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#2500 closed task (wontfix)

video conferencing system for AGM

Reported by: tadams Owned by: sac@…
Priority: normal Milestone: Unplanned
Component: Board Keywords:
Cc:

Description

Dear SAC,

for the AGM the board is still seeking for the appropriate video conferencing system. I did some pre-work and also already talked to Markus Neteler. For now, we see two options:

There are quite a few of such systems on the market and although I got in touch with many of them especially in the past month, I am far away from knowing all of them. Here are some overcviews [1] [2].

We could try some of them, at least from the list in [2] there are some promising candidates. The problem is, we will not be able to host it on the existing OSGeo servers, as Markus told me. Also we will not have the chance to try them in reality, as we will barely have the chance to try it out with 100 or 200 people.

So, in my eyes, there are two alternatives:

  1. Regarding the idea of using the Jitsy hosted service from FFMUC [3]

(I sent a sepearate email on this) we have the possibility to have few speakers and many followers, that follow the channel via youtube as - due to their own statement - Jitsy is not made for hosting video sessions with 200 or more people. They can offer several rooms. Pro: Open Source Tool, work together with another community, no costs Con: Few speakers

  1. Using zoom, which suitability for such an event was at least proven

by FOSS4G UK. Zoom also offers having several rooms. The costs are okay, the free account does not work, because the session time is limited to 40 minutes. The (in my eyes) appropriate account costs 15 US$/month per host plus an additional fee for larger number of participants (65$ for up to 500 participants). I am not sure, whether we need several accounts, if we offer several rooms, but I can figure out what we need exactly [4]. Pro: Reliable, as many speakers as we want Con: Not Open Source, costs of approx. 150-300 US $,

[1] https://www.g2.com/categories/video-conferencing/free [2] https://www.goodfirms.co/blog/best-free-open-source-web-conferencing-software-solutions [3] https://ffmuc.net/ [4] https://zoom.us/pricing

During a board meeting the wish came up to consult SAC and ask for your opinion in this issue.

It would be great, if someone from SAC could either contact me directly (adams@…) or comment into this ticket. Thanks!

Change History (12)

comment:1 Changed 2 months ago by robe

A) Hosting on OSGeo Servers at OSUOSL

In theory we could host it on OSGeo Servers as we do have a lot of server capacity now and still about 12 TB of space.

B) In practice I fear the network bandwidth requirements may make A) OSGeo Server hosting not ideal.

Another option to get around the bandwidth issues is just to setup a cloud server on some cloud hoster that offers high bandwidth and is not too expensive.

I would opt for installing LXD - so we could build it easily and move it to said cloud hoster and can easily bring it back in if cost becomes too high.

Ones that come to mind are hetzer (used by QGIS), atlantic.net (used by PostGIS), digitalocean, or linode (not sure if any projects are currently using digitalocean or linode, but I've heard good things about those in terms of feature, stability and price. On one of those we can set up a jitsi LXC instance.

C) Zoom -- I don't have anything personally against Zoom except the price seems much higher and high enough that we might not be able to sustain past the conference. On the plus side requires least amount of system admin care and feeding.

I like idea B the most in that we could use the extra server for mirroring downloads and a read-only repo.osgeo.org mirror.

comment:2 Changed 2 months ago by robe

Owner: changed from warmerdam to sac@…
Status: assignednew

comment:3 Changed 2 months ago by wildintellect

Can you clarify the specific requirements:

  1. How many speakers in the same session?
  2. Do you need multiple rooms?
  3. How do you want to take questions from the audience?

I did research on this topic when helping QGIS NA pick their solution, which was Zoom for the speaker streamed to Youtube for the audience. A pro zoom account through the hosts university was donated to do the streaming.

Also consider pre-recording, where each speaker records and submits their presentation, someone splices all those videos together, then it's streaming at the set time over something like Youtube or Twitch and everyone can participate in the text chat, which could be on an existing web chat solution which OSGeo already supports.

comment:4 Changed 2 months ago by tadams

Hi,

  1. no real idea, I think in the main session we will have about 20-25 speakers.
  2. yes, we want to open some discussion rooms afterwards
  3. Either directly (speak) or via chat and one person asks the questions, just like they fdid at FOSS4G UK Online this year.

I think the latter is no real option (I will propose it to the board in our meeting today anyhow)

comment:5 in reply to:  1 ; Changed 2 months ago by tadams

Replying to robe: Regarding_

B) In practice I fear the network bandwidth requirements may make A) OSGeo Server hosting not ideal.

Which video system would you then install? Is it capable for at least 300 people? How much effort would it be for SAC?

comment:6 Changed 2 months ago by wildintellect

I would not install anything, this is a great case for outsourcing to an existing platform that can handle the audience well. It's only likely to cost $20 (or less if someone has an account they can use already) and seems well worth it.

comment:7 in reply to:  6 Changed 2 months ago by robe

Replying to wildintellect:

I would not install anything, this is a great case for outsourcing to an existing platform that can handle the audience well. It's only likely to cost $20 (or less if someone has an account they can use already) and seems well worth it.

What platform are you thinking of that would cost only $20? Is that a one time or monthly? I haven't heard of any. How much did FOSS4G.UK spend?

comment:8 in reply to:  5 Changed 2 months ago by robe

Replying to tadams:

Replying to robe: Regarding_

B) In practice I fear the network bandwidth requirements may make A) OSGeo Server hosting not ideal.

Which video system would you then install? Is it capable for at least 300 people? How much effort would it be for SAC?

I don't have little experience with recording platforms. So my guess is probably worse than yours. Jitsi and Zoom are pretty much the only ones I've used and not anywhere near 200 people on audience.

From what I can gather I think Jitsi would be fairly easy to set up and maintain (so just the bandwidth like I said which can easily be solved with YouTube/Cloud? Hosting service), but it sounds like it would not fit your audience requirement- or is that the hosted one used for non-profits as a service?

To Alex's note -- I think if we can find a service that say is < $50 / mth and can satisfy our needs, it might be well worth paying for the service. Ideally we'd want one that we pay as we need it, as once the conference is over, we'd be collecting the videos anyway and broadcasting on youtube and twitch.

comment:9 Changed 2 months ago by tadams

I have a resilient statement that says, that jitsy is not made for more than 20+x people. Using Jitsy with live streaming on youtube is a solution, that the FFMUC ("Freifunker" - a community of so called free radio operators) offered to us and that also told us about the capacities that Jitsy offered.

As we are running out of time (sorry, I also caused some delay due to my duties in my job) the board yesterday decided to go on zoom, as we can be confident, that zoom will work out (see experience gathered from FOSS4G UK). Zoom also allows recording, so we can afterwards put the stream on Youtube and other channels.

In general and in these uncertain times, maybe it's worth thinking about a general OSGeo solution, as my guess is, that even if COV19 disappears once upon a time, the format of online conferences will remain. As this has nothing to do with this request, I would suggest to close this ticket and thank you very much.

comment:10 Changed 2 months ago by robe

Resolution: wontfix
Status: newclosed

comment:11 Changed 2 months ago by wildintellect

To be clear I was talking about Zoom, is $14.99 a month, and we only need it for 1 month. Up to 100 people on the call, but I would suggest only the panelists/speakers - livestream to youtube unlimited audience, questions via text chat on youtube.

comment:12 Changed 2 months ago by kalxas

Thanks all for the update, we are planning to host on Zoom, with a plan for 1 month.

Note: See TracTickets for help on using tickets.