Opened 11 months ago

Closed 9 months ago

#2044 closed task (fixed)

Move all LDAP registration scripts to id.osgeo.org

Reported by: robe Owned by: sac@…
Priority: normal Milestone: Website rebranding 2017
Component: Systems Admin Keywords:
Cc:

Description

On list of things to do.

Right now where people change their password and email etc. via LDAP is here:

https://www.osgeo.org/user

This page will no longer exist once the site moves to Wordpress.

So we'll need to think about where this should live or if there is a way to build into the new wordpress site easily

Change History (10)

comment:1 Changed 11 months ago by wildintellect

That page looks like the Drupal the login, did you mean this page http://www.osgeo.org/osgeo_userid? Should be as simple as making a page in the new site with the same information.

Side question, did we plan to let users use Wordpress to register accounts, and reset passwords?

comment:2 Changed 11 months ago by robe

No I meant the one I mentioned -- ​https://www.osgeo.org/user

That one allows you to change your name and your LDAP password (it has a whole tab for LDAP) in fact. I just confirmed that if I change my first name on that tab, and then log into my test gitea instance, it shows the name I changed my name too.

Though the osgeo_userid one would need changing as well I guess, though that lets you do less so is redundant with ​https://www.osgeo.org/user (I have to double check the password I change from https://www.osgeo.org/user does change my LDAP password).

comment:3 Changed 11 months ago by robe

Okay just confirmed, if I change my password on:

https://www.osgeo.org/user

it DOES change my LDAP password.

So that means https://www.osgeo.org/cgi-bin/auth/ldap_edit_user.py (which is pointed to from http://www.osgeo.org/osgeo_userid? is redundant (since that one doesn't let me change my First name, but https://www.osgeo.org/user does.

comment:4 Changed 11 months ago by strk

That page (the drupal one) should not even be there, I think it's ticketed but nobody handled to retire it

comment:5 Changed 11 months ago by strk

here's the ticket: https://trac.osgeo.org/osgeo/ticket/1757 which reminds me the other reason why it should not be there (the drupal one): it lacks logging

comment:6 Changed 10 months ago by robe

Summary: Update LDAP user info needs to be rewired after we move to wordpressMove all LDAP registration scripts to id.osgeo.org

I reworded this because in discussion we decided maybe the LDAP stuff should have it's own dedicated domain:

[15:21] <strk> or https://id.osgeo.org/userid/create
[15:21] <strk> id.osgeo.org/userid/edit
[15:21] <strk> id.osgeo.org/userid/create

comment:7 Changed 10 months ago by strk

I think we should deprecate ​https://www.osgeo.org/user, that page was drupal-specific while the ones pointed to by /osgeo_userid are generic, under our own control and logging in a central place all operations. If First Name is missing in the form we'll want to add it (there and in the edit form). Feel free to ticket those enhancements.

comment:8 Changed 10 months ago by strk

It looks like id.osgeo.org is already pointing to "www" machine, so next step would be configuring apache to provide that virtual host, with proper ssl/letsencrypt, and expose those nice URLs....

comment:9 Changed 9 months ago by cvvergara

Checking the status of all open tickets of the milestone due on Jan/15/2017

Any update?

comment:10 Changed 9 months ago by strk

Resolution: fixed
Status: newclosed

This is done, detailed URLs on http://www.osgeo.org/osgeo_userid (same url on staging)

Note: See TracTickets for help on using tickets.