Opened 3 years ago

Closed 3 years ago

#1830 closed defect (worksforme)

CS-Map SVN server

Reported by: normanb Owned by: sac@…
Priority: normal Milestone:
Component: Systems Admin Keywords:
Cc: normolsen

Description

There have been a couple of issues reported with the CS-Map SVN server

http://osgeo-org.1560.x6.nabble.com/Cannot-submit-code-to-CS-Map-SVN-server-td5299529.html http://osgeo-org.1560.x6.nabble.com/Submission-failed-td5296668.html

I am also getting this issue trying to export from SVN

Running svnrdump fails with

Access to '/metacrs/!svn/vcc/default' forbidden

Change History (19)

comment:1 Changed 3 years ago by normanb

Hi, any update on this please? It is a blocker.

comment:2 Changed 3 years ago by strk

Sounds like the user is failing to use https for posting ?

comment:3 Changed 3 years ago by strk

What does svn info give you ?

comment:4 Changed 3 years ago by strk

NOTE: "normanb" is not part of the "metacrs" group, so is not allowed to commit code. Group composition can be seen here (by registered users):

https://www.osgeo.org/cgi-bin/auth/ldap_group.py?group=metacrs

comment:5 Changed 3 years ago by normanb

svn info below, I get the same error with either https or http, I can't comment on the other two people with the same issue.

I am not trying to commit code, I am trying to fork to github. Norm Olsen also reported this error and he has commit access.

svn info https://svn.osgeo.org/metacrs/csmap/trunk/CsMapDev/
Path: CsMapDev
URL: https://svn.osgeo.org/metacrs/csmap/trunk/CsMapDev
Relative URL: ^/csmap/trunk/CsMapDev
Repository Root: https://svn.osgeo.org/metacrs
Repository UUID: 4e78687f-474d-0410-85f9-8d5e500ac6b2
Revision: 2745
Node Kind: directory
Last Changed Author: steffen
Last Changed Rev: 2717
Last Changed Date: 2016-01-18 00:35:10 -0600 (Mon, 18 Jan 2016)

comment:6 Changed 3 years ago by strk

Does github allow forking from SVN ? I can checkout from the SVN just fine, can't you ?

svn checkout https://svn.osgeo.org/metacrs/csmap/trunk/CsMapDev

svn, version 1.8.10 (r1615264)

Can the one having the problem give feedback here ? If not else we'd know if he can still login to LDAP...

comment:7 Changed 3 years ago by strk

Cc: normolsen added

For the record, normolsen does have rights to push (answering his question on the list)

comment:8 Changed 3 years ago by normanb

I logged in using ldap (normanb) to view the metacrs group. I am the one having problems exporting from SVN. Others have reported similar issues (as in the ticket) but they may be unrelated.

For me svnrdump fails with

Access to '/metacrs/!svn/vcc/default' forbidden

I can checkout from svn just fine.

comment:9 Changed 3 years ago by strk

Ok I could reproduce:

svnrdump dump https://svn.osgeo.org/metacrs/csmap/trunk/CsMapDev > CsMapDev.svndump
* Dumped revision 0.
* Dumped revision 1.
* Dumped revision 2.
* Dumped revision 3.
* Dumped revision 4.
* Dumped revision 5.
* Dumped revision 6.
svnrdump: E175009: XML parsing failed: (403 Forbidden)

Checking

comment:10 Changed 3 years ago by strk

It might have to do with DOS protection as looking at the logs it seems that svnrdump hits the server heavily

comment:12 Changed 3 years ago by strk

Just as a possible workaround, while we try to fix the issue, I've been mirroring SVN repositories to git via git-svn. As you mention a checkout worked, I guess a git svn clone would also work, then you can setup you remote and push there.

comment:13 Changed 3 years ago by strk

Confirmed. The dump makes more than 5 requests to the same URL within the same second. It's not the first time we see such weird behavior from SVN client. Let me know if the git svn clone solution helps.

comment:14 Changed 3 years ago by strk

I've raised the allowed number of hits per second, please see if it works for you now

comment:15 Changed 3 years ago by normanb

svnrdump is failing, just at a later point in the process.

I think git svn clone will work, thank you for the help.

comment:16 Changed 3 years ago by strk

What's the IP you're dumping from ? The only trace of DOS protection I find are for the IP I'm doing tests from and an amazonaws ip, but last trace is before your comment

comment:17 Changed 3 years ago by normanb

I am going from github.com which is running svnrdump (they emailed me when I asked them why it was failing).

Looks like git svn clone is working and I am pushing to a git repo now.

https://github.com/normanb/CS-Map

Thanks

comment:18 Changed 3 years ago by strk

I'd close this as fixed then. I hope we can soon move everything out of SVN and into GIT. BTW, did you give git.osgeo.org a try yet ? :)

comment:19 Changed 3 years ago by strk

Resolution: worksforme
Status: newclosed

assuming the problem is solved

Note: See TracTickets for help on using tickets.