Opened 12 years ago

Closed 11 years ago

#171 closed task (fixed)

SVN, Trac and Lists for Fusion

Reported by: dmorissette Owned by: sbarnes
Priority: normal Milestone:
Component: Systems Admin Keywords:
Cc: pagameba, sbarnes

Description

We would like to request the following services from OSGeo for the new "Fusion" Open Source project:

  • SVN
  • Trac
  • mailing lists: fusion-users and fusion-dev

Fusion is a new AJAX application development framework for MapGuide and MapServer. It has been developed by DM Solutions and they have announced their intention to open source it at FOSS4G2006 (MIT/X11 license).

A snapshot of Fusion is already available as part of the MapGuide Open Source project, however, we believe that those SVN, Trac and Mailing list services from OSGeo would be really helpful for Fusion to become a real open source project and build up a community of users and developers around it. Once Fusion has built up a community and matured a bit it will likely apply for OSGeo incubation, but it's not there yet.

What are the steps to ask OSGeo to consider providing those services to the new Fusion project? Is this ticket sufficient?

Change History (11)

comment:1 Changed 12 years ago by dmorissette

Cc: pagameba added; pspencer removed

comment:2 Changed 12 years ago by dmorissette

Oh, BTW, DM Solutions has been using Trac and SVN internally for Fusion development. Shawn could take care of the migration of the Trac/SVN stuff to OSGeo servers.

comment:3 Changed 12 years ago by warmerdam

Cc: sbarnes added

The normal process is that you would make a motion to SAC to provide the service. This motion should include a volunteer with admin access willing to do the work. Once approved by SAC the issue is referred to the board for approval.

This means we can't practically proceed with the work till after the early December board meeting.

comment:4 Changed 12 years ago by dmorissette

I got confirmation that Shawn can take care of the setup of the new services and have raised a motion on the SAC list. Waiting on response from SAC and the board.

comment:5 Changed 12 years ago by dmorissette

The following motion has passed on the SAC list with +1 from DanielM, FrankW and ShawnB:

-------------------
I would like to motion that OSGeo/SAC provide the following services for the
Fusion project, with Shawn Barnes taking care of the setup of the new services:
    * SVN
    * Trac
    * mailing lists: fusion-users and fusion-dev
------------------- 

... waiting on board approval.

comment:6 Changed 12 years ago by warmerdam

Unfortunately we missed the board meeting by a few hours (it was this morning) and the next one will presumably be in January. I have made a motion to adjust our procedure to just require non-objection by the board in two business days and provided notification about the Fusion request. If the motion passes, by Wednesday we can start setting up fusion services on osgeo systems.

comment:7 Changed 12 years ago by dmorissette

Frank, were there any objections raised by the board? Could Shawn go ahead and setup the services for Fusion now?

comment:8 Changed 12 years ago by warmerdam

Daniel,

Sorry about that. There were no objections by the board so this can go ahead at will.

comment:9 Changed 12 years ago by dmorissette

Owner: changed from sac@… to sbarnes

Reassigned ticket to Shawn to setup the services.

comment:10 Changed 11 years ago by warmerdam

I'm under the impression this is done, is that right Shawn? Can the ticket be closed?

comment:11 Changed 11 years ago by dmorissette

Resolution: fixed
Status: newclosed

I'm not aware of any pending issue. Closing.

Note: See TracTickets for help on using tickets.