Opened 3 years ago

Closed 3 years ago

#1547 closed task (invalid)

Move mails to Gmail

Reported by: jachym Owned by: sac@…
Priority: normal Milestone:
Component: Systems Admin Keywords:
Cc:

Description

According to last board meeting http://wiki.osgeo.org/wiki/Board_Meeting_2015-09-19#Motions_.28confirmed_by_email.29

I created osgeo.org bussiness acout by Google and I would like to setup some mail addresses and aliases for already existing users we have at our servers (e.g. president@…, but also private mails)...

Could you help me please on that?

Change History (14)

comment:1 Changed 3 years ago by martin

When making decisions concerning SAC work, why don't you negotiate with the affected people *beforehand* ? Or did you actually do so and I just didn't notice ?

I'm in the middle of preparations for migrating the OSGeo Mail to our shiny new hardware "osgeo6" because that's been marked as being essential:

http://lists.osgeo.org/pipermail/sac/2015-August/005741.html

.... and I wonder from where I should draw motivation to continue this sort of work when I'm at risk that people are obsoleting my work just the next day without prior notice (!).

comment:2 Changed 3 years ago by warmerdam

Jachym, I assume one of the things you need is access to the aliases file currently used for the various @osgeo.org email addresses? I can get that for you if it helps. Is there anything else you were wanting? Were you thinking that the OSGeo secretary role would be responsible for the @osgeo.org level email forwarding via Google? Or were you wanting SAC to administer this Google account?

Martin, I assume your migration was primarily the mailman services, right? I'm pretty sure that isn't what Jachym is talking about and that is certainly still a critical service.

comment:3 Changed 3 years ago by martin

I'm migrating all of OSGeo mail in order to prevent things from breaking down due to hardware failure on "osgeo4" (see Alex' posting).

Unfortunately it's unclear to me what the actual intention is. If they're aiming at registering "@osgeo.org" addresses with Google then things might get slightly complicated because "@osgeo.org" is being hosted at OSGeo infrastructure, not at Google.

In any case they should discuss their plans with active admins *before* making decisions.

comment:4 Changed 3 years ago by jachym

Hi Martin,

yes, I'm aware, it might look bad from your perspective. Take this ticket (and mail) as exactly start of the discussion (we can always close it down, but SAC is always requiring tickets, so here I am).

As Frank writes: this meant to be for easier control of mails of individual people - there is no plan (and no reason so far) to move the whole mailing list infrastructure to any external service provider.

Also as Frank writes: yes, management of individual mails (e.g. for board members and other official roles) could be therefore managed by secretary (for the moment, it's me) and SAC could focus on more important tasks then (sorry, if it looks, like a try to get rid of SAC - absolutely NO, we would like you to focus on important thinks, not to switch mail addresses every two years).

Frank: I have actually the list of aliases (send by Jorge), but coordination with SAC is a must, if I understand correctly, we would like to move only few accounts to Google, not the whole alias file. I would appreciate any help in that.

NOTE: There is more we are trying to fix with that. Files sharing with access control, collaborative document writing, etc.

comment:5 Changed 3 years ago by martin

The point is:

We can't split "<whichever_name>@osgeo.org" between OSGeo infrastructure and Google. We either need to move *every* genuine address in the "@osgeo.org" namespace to Google or *none*. Just moving some central, administrative addresses like "president@…" or "treasurer@…" to Google and keeping other addresses in the same namespace on our own infrastructure is close to technically impossible (it might be possible but *if* it works it'll be a terrible hack and you certainly don't want to be responsible for debugging if it fails).

Of course we can set up a forwarder to accept "president@…" on our own infrastructure first and afterwards map it to a different address at Google (or somewhere else), but that's what we're already doing right now with some addresses (including "president") and doesn't require any changes.

If everything you're aiming at is a means to facilitate management of private mailboxes in "@osgeo.org" namespace, then "postfixadmin" might be the tool you want - to be run on our own mailserver. Setting up such a tool is a *lot* easier than maintaining ugly hacks.

Therefore: Please negotiate *before* making decisions.

comment:6 Changed 3 years ago by wildintellect

In my email to the board, I specifically asked for a ticket in order to discuss the options. This ticket should not require any action beside research into how we might outsource the @osgeo.org mailboxes, and to which services might be used.

I'm a -1 on any immediate actions to reconfigure specifically because there has no been discussion or plan made.

Things to do:

  1. Figure out what services and how many boxes this affects
  2. Make a list of 3rd party mail services with pros/cons/cost
  3. Figure out what configuration changes would need to happen on our end
  4. Figure out how to grant access to the right people to the correct boxes.

We need people to please volunteer to tackle each of these tasks and should put all the information in a wiki page. Then we can give the information to the board for their choice and schedule an implementation timeline.

comment:7 Changed 3 years ago by astrodog

Unfortunately, there's no particularly clean way to make this kind of split. The MX record for osgeo.org has to point to a specific set of infrastructure. This means that the only three options are:

  • Keep the MX record pointed at OSGeo, and set up aliases there to forward things for specific addresses to third-party services. (As I understand things, this is how it works now)
  • Point the MX record at Google, and set up forwarding or mailbox collection there to deliver some subset of the addresses running to OSGeo. This is probably the most technically fragile option.
  • Point the MX record for "osgeo.org" to Google, and the MX record for "lists.osgeo.org" to OSGeo's infrastructure. This takes care of the mailing lists, but means all osgeo.org addresses are hosted at google.

There isn't a way, technically, to have mail for a single host effectively split between two providers. In the end, it has to be forwarded from one side to the other. That isn't too terrible to accomplish, but it means properly functioning infrastructure depends on *both* sets being up, which may not be what people are intending here.

From a time management perspective, it's also worth keeping in mind that all of these options also require manual intervention from SAC to handle new addresses, lists, etc.

comment:8 Changed 3 years ago by wildintellect

I think option 3 is what is likely:

"Point the MX record for "osgeo.org" to Google, and the MX record for "lists.osgeo.org" to OSGeo's infrastructure. This takes care of the mailing lists, but means all osgeo.org addresses are hosted at google"

Which implies, that yes all @osgeo.org addresses would be 3rd party outsourced managed. It sounds like a service with a good management interface, including aliases would be a requirement.

comment:9 Changed 3 years ago by msmitherdc

What about using a different domain, something like osgeo.io or something similar and just keep the @osgeo.org redirects to those new addresses?

comment:10 in reply to:  9 Changed 3 years ago by wildintellect

Replying to msmitherdc:

What about using a different domain, something like osgeo.io or something similar and just keep the @osgeo.org redirects to those new addresses?

How is that different from the current arrangement? Where current users can choose any email service they want their alias to point to. Google, Thunderbird, etc are smart enough to be able to reply as alias based on the To: And would require 0 new work on SAC side.

comment:11 Changed 3 years ago by jachym

@wildintellect, @martin: yes this ticket was meant as "starting point for discussion" (even I agree, it seems to be formulated as "taking action, deal with it" - sorry for that).

Our target is (to state more clearly): Take some work from SAC and transfer it to e.g. secretary, so we can be more flexible, e.g. setting up mails (e.g. new board members, every 2 years), keeping track of mails for representatives (when secretary changes, he/she should have history of the previous mails for some unresolved tasks e.g.), easier file sharing etc. (already mentioned).

I'm not very familiar with setting up mail infrastructure, but I can understand, that "splitting" one domain between more servers is not technically possible. Any proposal (like @osgeo.org to external service, @mail.osgeo.org to osgeo, or osgeo.io to google, and few mail forwards from osgeo.org to external service ..) is welcomed.

I'm really asking SAC for best solution on this: you are the once, who will have to set things up, I believe, you will come up with best solution. If there is anything I could do for your support, let me know please.

comment:12 Changed 3 years ago by martin

To be honest, I'm still waiting for a clear description of what you're aiming at. Most proposals in this thread still look to me like defining the goal via the favourite tool. That's the wrong direction, I'd say (like hammering screws into the wall because hammering looks easier to you than using a screwdriver, and btw., the hammer is cheaper ....).

If everybody agrees that the underlying intention wrt. EMail is to facilitate maintenance of private EMail accounts within the "@osgeo.org" domain, then let's declare this as the basis for a discussion on how to get there. If not, then let's _refine_ the goal but _refrain_ from evaluating the tools before the goal is clear.

comment:13 in reply to:  11 Changed 3 years ago by neteler

Replying to jachym:

@wildintellect, @martin: yes this ticket was meant as "starting point for discussion" (even I agree, it seems to be formulated as "taking action, deal with it" - sorry for that).

As a SAC member, I strongly recommend to the board to set up a *wiki* page describing their goals. A ticket system is not ideal for a discussion and wishes and comments are already scattered here over 11+ comments.

The stated target to "Take some work from SAC" is nice but not yet clear at all. "setting up mails (e.g. new board members, every 2 years)" takes rather seconds than minutes and is not an issue at all.

I am guessing that you want to provide mailboxes to some OSGeo roles or to some community members or to..? Please add this to the wiki page. You want file sharing tools like self-hosted owncloud/seafile for the board? Likely doable.

As a SAC member I don't agree to the view that all stuff should be outsourced to 3ed parties for the following reasons

  • sensitive data should be hosted on OSGeo hardware to keep control.
  • nobody knows about the future of the respective 3rd party services.
  • OSGeo SAC members are happy to contribute to the infrastructure maintenance. It is also a way for us to keep up to date with technology. Obviously things can be improved as always in life.
  • An OSGeo which would literally come without infrastructure is too virtual for me.

Selected stuff may be outsourced but only after a careful assessment and SWOT.

If there is anything I could do for your support, let me know please.

Yes: create a Wiki page and collect all information there which has already been asked in this ticket. Add that we discuss individual mailboxes here, not the list server with mailman.

comment:14 Changed 3 years ago by jachym

Resolution: invalid
Status: newclosed

@neteler: that makes sense too .. ok, closing this ticket and creating wiki http://wiki.osgeo.org/wiki/Board_infrastructure

Note: See TracTickets for help on using tickets.