Opened 15 years ago

Closed 15 years ago

#133 closed task (fixed)

MySQL error when trying to update wiki.osgeo.org, or upload files

Reported by: dmorissette Owned by: sac@…
Priority: critical Milestone:
Component: Systems Admin Keywords:
Cc: adams@…

Description

When I try to save changes to http://wiki.osgeo.org/index.php?title=FOSS4G2007_Information_for_Instructors I get the following MySQL error:

Database error
From OSGEO
Jump to: navigation, search
A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:

    (SQL query hidden)

from within function "SearchMySQL4::update". MySQL returned error "1016: Can't open file: 'osgeo_searchindex.MYI' (errno: 145) (localhost)".

Change History (7)

comment:1 by dmorissette, 15 years ago

Component: GeneralSAC
Owner: changed from tmitchell to sac@…

comment:2 by dmorissette, 15 years ago

Just found after going back to the page that my changes were saved even if I got the error.

comment:3 by tmitchell, 15 years ago

Cc: adams@… added

Seems to be a problem with any page, I think. I did a few tests and had same results as you.

Till - was the database upgraded and causes this error? Can you help fix it?

Tyler

comment:4 by tmitchell, 15 years ago

Looks like the problem might be solved by repair the 'searchindex' table:

  • Login to mysql command prompt
  • REPAIR TABLE searchindex

Till is looking into it but repair may be delayed until their admin returns next week.

comment:5 by dpatton, 15 years ago

Priority: normalcritical
Summary: MySQL error when trying to update wiki.osgeo.orgMySQL error when trying to update wiki.osgeo.org, or upload files

This problem needs to be fixed ASAP:

1) Some of the wiki pages are critical infrastructure for the FOSS4G2007 conference.

In particular, the Information for Instructors wiki page: http://wiki.osgeo.org/index.php/FOSS4G2007_Information_for_Instructors

The problem with this error is that we have told all the Instructors that they must edit that wiki page, and having them encounter an error when doing so reflects poorly on OSgeo and FOSS4G2007.

2) It appears that the error is either preventing file uploads, or masking relevant error messages relating to failed file uploads.

I'm trying to upload PDF floor plans for the FOSS4G2007 conference centre, and encountering an error:

  • after ignoring the bogus message "It is recommended that images not exceed 153600 bytes in size, this file is 387555 bytes"(my upload is a PDF file, not an image)
  • I used the "Ignore warning and save file anyway." Save File button
  • I get the same error as above:

MySQL returned error "1016: Can't open file: 'osgeo_searchindex.MYI' (errno: 145) (localhost)".

  • My PDF is not uploaded(it is not in the Upload log)

comment:6 by dpatton, 15 years ago

As far as I am concerned this issue is fixed.

Wiki page editing doesn't generate an error, and the upload of the same PDF file that previously failed is now working.

Thanks

comment:7 by dmorissette, 15 years ago

Resolution: fixed
Status: newclosed

I checked and saving changes no longer produces the error. Marking fixed.

Note: See TracTickets for help on using tickets.