Opened 12 years ago

Closed 12 years ago

#2607 closed defect (duplicate)

TEXT "© xxx" does not work consistently with GD and AGG

Reported by: woodbri Owned by: tbonfort
Priority: normal Milestone: 5.2 release
Component: AGG Version: unspecified
Severity: normal Keywords:
Cc: jmckenna

Description

Using gd the declaration "©"renders the "copyright"-Sign:

LAYER
  NAME "copyright"
  REQUIRES ..
  ...

  FEATURE
     POINTS
      3 10
     END
   END
   
 ...

  CLASS
    TEXT "© xxx"
    LABEL
      TYPE TRUETYPE
      FONT 'arial'
      SIZE 9
      POSITION cr
      COLOR 0 0 0
      OUTLINECOLOR  255 255 254
    END
  END
 
END # LAYER

But using agg, the text ""© xxx" is rendered in the map.

Please lokk at the examples !

Does anybody know, how to render the html-code like done in gd ?

Does anybody know another way to render signs like "copyright" with gd ?

Thanks very much

greetings Herbert

Attachments (2)

gd-rendering.gif (4.3 KB) - added by woodbri 12 years ago.
gd-rendered version
agg-rendering.gif (4.3 KB) - added by woodbri 12 years ago.
agg rendered version

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by woodbri

Attachment: gd-rendering.gif added

gd-rendered version

Changed 12 years ago by woodbri

Attachment: agg-rendering.gif added

agg rendered version

comment:1 Changed 12 years ago by jmckenna

Cc: jmckenna added

comment:2 Changed 12 years ago by dmorissette

This may be related to ticket #2600 (or not?)

comment:3 Changed 12 years ago by woodbri

Jeff McKenna? provided this work around on the list:

What about using your operating system's character set? For example on windows pressing ALT-0169 gives the copyright sign, and on MAC pressing OPTION-G. So your mapfile snippet is: TEXT "©"

comment:4 Changed 12 years ago by tbonfort

Resolution: duplicate
Status: newclosed

more or less a duplicate of #2403 - or at least the fix for 2403 also fixed this one

Note: See TracTickets for help on using tickets.