Opened 14 years ago

Closed 9 years ago

#1652 closed defect (worksforme)

md5.c contains obnoxious RSA licence

Reported by: pabs3@… Owned by: warmerdam
Priority: normal Milestone: 6.0 release
Component: MapServer C Library Version: unspecified
Severity: normal Keywords:
Cc:

Description (last modified by warmerdam)

I suggest replacing the md5.c/md5.h from RSA with the public domain
implementation from Colin Plumb. It should be a drop-in replacement for the RSA
one. The reason for this is that the RSA licence has an obnoxious advertising
clause (like the original BSD licence).

You can find a copy of that here: http://www.fourmilab.ch/md5/md5.tar.gz

Change History (2)

comment:1 Changed 9 years ago by warmerdam

Description: modified (diff)
Milestone: 6.0 release
Priority: highnormal
Status: newassigned

Investigating...

comment:2 Changed 9 years ago by warmerdam

Resolution: worksforme
Status: assignedclosed

On review the md5 code was removed from MapServer somewhere after 4.10 and before 5.2. So the problem is resolved by removal rather than replacement.

Thanks for the suggestion, reviewed rather belatedly.

Note: See TracTickets for help on using tickets.