Opened 9 years ago

Closed 9 years ago

#2079 closed defect (fixed)

MapGuide Selection When Legend Hidden

Reported by: crispinatime Owned by:
Priority: high Milestone: 2.4
Component: AJAX Viewer Version: 2.4.0
Severity: blocker Keywords:
Cc: External ID:


When the legend is turned off on an AJAX WebLayout? none of the features on the map layers are selectable.

This is a regression since 2.2 (maybe 2.1) and makes embedded applications / maps without a legend but requiring selectable features unusable.

MapGuide 2.4 RC, AJAX Map Viewer

Change History (9)

comment:1 Changed 9 years ago by jng

How did MGOS < 2.1 do this? Querying for selectable layers is doing a GetLayers?() against the legend frame, which doesn't exist if the legend is turned off in the WebLayout?

comment:2 Changed 9 years ago by crispinatime

MGOS 2.1 and 2.2 are both OK (you can select when legend is turned off).

I though it might be to do with but I backed out that change and the behaviour is still the same - no selectability!

I think this is actually a blocker IMHO

comment:3 Changed 9 years ago by crispinatime

It was this change that caused the regression (confirmed by backing out):

ajaxmapmape.templ calls GetVisSelLayers?() from QueryFeatureInfo?()

This in turn calls "GetLayers?(true, true);" from legendui.templ

In the fix for 1318 there is a new check for "node.curScale" ... but this always appears to be undefined when I run a weblayout with or without a legend shown

comment:4 Changed 9 years ago by jng

Not disputing the severity of this issue. Just needed confirmation that this once worked in the past.

comment:5 Changed 9 years ago by crispinatime

Yes, this worked until 3 July with the 1318 patch. Appreciate that patch was for one issue but as a side effect it has created this one!

comment:6 Changed 9 years ago by jng

Please try r6917 and confirm if this fixes the issue. If you installed 2.4 RC1, just svn update viewerfiles in your www directory and you'll get this change pulled down.

comment:7 Changed 9 years ago by jng

Installed 2.4 RC1 with SVN metadata feature enabled. That is. Otherwise just manually edit ajaxmappane.templ as per r6917 and please confirm.

comment:8 Changed 9 years ago by crispinatime

Ran SVN update to get the fix - now works as previously/expected!

comment:9 Changed 9 years ago by jng

Resolution: fixed
Status: newclosed

Fixed 2.4 (r6917) and trunk (r6918)

Note: See TracTickets for help on using tickets.