Opened 11 years ago

Closed 10 years ago

#916 closed defect (fixed)

GRASS 7: make install fails with --prefix

Reported by: neteler Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: Default Version: svn-trunk
Keywords: Cc: martin
CPU: Unspecified Platform: Linux

Description

When using

./configure --prefix=/some/path

compiling and then running

make install

a series of bugs appear which indicate that the --prefix path was not properly propagated. The problem might be that the Makefile no longer has an "install" target (guessing).

Markus

Change History (6)

comment:1 Changed 11 years ago by hamish

can you post the errors? I recently added pathname variable quoting to ./install-sh and may have got over zealous with it.

Does it happen with 6.5 or 6.4? (changes were backported)

Hamish

comment:2 Changed 11 years ago by hamish

ah,

Casey Vandenberg wrote:

I was trying to install grass7.0 through svn so I could do some testing and see some of the future development. I had no errors after typing in make, but when I make install I get the following:

root@silver:/usr/local/src/grass_trunk# make install
echo /usr/local/src/grass_trunk/bin.x86_64-unknown-linux-gnu/grass70
/usr/local/src/grass_trunk/bin.x86_64-unknown-linux-gnu/grass70    make[1]: Entering directory `/usr/local/src/grass_trunk'           test -d /usr/local/grass-7.0.svn || mkdir -p -m 755 /usr/local/grass-7.0.svn
test -d  || mkdir -p -m 755                                                sed -e "s#^GISBASE.*#GISBASE=/usr/local/grass-7.0.svn#" /usr/local/src/grass_trunk/bin.x86_64-unknown-linux-gnu/grass70.sh > /grass70.sh
sed -e 's#^gisbase = ".*"#gisbase = "/usr/local/grass-7.0.svn"#' /usr/local/src/grass_trunk/bin.x86_64-unknown-linux-gnu/grass70 > /grass70
chmod a+x /grass70                                                                                                                         
tar cBCf /usr/local/src/grass_trunk/dist.x86_64-unknown-linux-gnu - . | tar xBCf /usr/local/grass-7.0.svn - 2>/dev/null                   sed 's#'/usr/local/src/grass_trunk/dist.x86_64-unknown-linux-gnu'#'/usr/local/grass-7.0.svn'#g' /usr/local/src/grass_trunk/dist.x86_64-unknown-linux-gnu/etc/fontcap > /usr/local/grass-7.0.svn/etc/fontcap
/usr/bin/install -c  config.status /usr/local/grass-7.0.svn/config.status
chmod -R a+rX /usr/local/grass-7.0.svn 2>/dev/null
tar cBf - gem/skeleton | tar xBCf /usr/local/grass-7.0.svn/etc - 2>/dev/null
/usr/bin/install -c  gem/gem70  2>/dev/null
make[1]: [real-install] Error 1 (ignored)
make[1]: Leaving directory `/usr/local/src/grass_trunk'

so is that in GEM or, ... ?

comment:3 in reply to:  description Changed 11 years ago by glynn

Replying to neteler:

a series of bugs appear which indicate that the --prefix path was not properly propagated. The problem might be that the Makefile no longer has an "install" target (guessing).

The "install" target is in Install.make, which is "include"d from the top-level Makefile.

The problem is that r40491 removed the "BINDIR=${UNIX_BIN}" with the intention of just using $(UNIX_BIN) instead, but didn't follow through.

Fixed in r40882.

comment:4 Changed 11 years ago by martin

Cc: martin added

comment:5 Changed 11 years ago by neteler

Thanks, the "make install fails with --prefix" problem appears to be solved.

Not sure about Casey's problem (maybe the same).

Markus

comment:6 Changed 10 years ago by neteler

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.