Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#782 closed enhancement (wontfix)

Please provide swig generated stuff in distributed tarballs

Reported by: frankie Owned by: grass-dev@…
Priority: normal Milestone: 6.4.0
Component: Python ctypes Version: svn-trunk
Keywords: Cc:
CPU: Unspecified Platform: All

Description

See for instance http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=549867. While it is perfectly reasonable avoiding that on svn, providing swig stuff for a well-tested reference swig version would help a lot distributions. Swig upgrades are generally done system-wide and out of control of packagers, and compatibility issues (often subtle) can raise from time to time. At the same time, sometimes regeneration has to be forced occasionally. Other softwares (e.g. gdal) have a suitable .PHONY target to force regeneration of swig stuff on demand in dist tarballs. That would help a lot.

Change History (9)

comment:1 Changed 10 years ago by frankie

Milestone: 6.4.06.5.0

comment:2 Changed 10 years ago by neteler

Milestone: 6.5.06.4.0

I have downgraded swig, recompiled 6.4 from scratch and still no wxGUI (it comes up when removing wx-nviz and wx-vdigit):

GRASS 6.4.0svn (nc_spm_08):~/grass64/dist.x86_64-unknown-linux-gnu/etc/wxpython/vdigit > ldd _grass6_wxvdigit.so  | grep wx
        libwx_gtk2u-2.8.so.0 => /usr/lib/wxPython/lib/libwx_gtk2u-2.8.so.0 (0x00007f2d1f12f000)

swig -version
SWIG Version 1.3.36

Do I have to recompile all wx RPM packages as well?

Markus

comment:3 in reply to:  2 Changed 10 years ago by neteler

Replying to neteler:

I have downgraded swig, recompiled 6.4 from scratch and still no wxGUI (it comes up when removing wx-nviz and wx-vdigit):

For the record:

this problem is solved and was caused by an expat problem (see https://qa.mandriva.com/show_bug.cgi?id=57960). wx-nviz and wx-vdigit work fine also with swig 1.3.40.

comment:4 Changed 9 years ago by hamish

Resolution: wontfix
Status: newclosed

Hi, swig has now been removed from GRASS in favour of the less problematic Python ctypes. ctypes support is not yet in the 6.4.x release branch, and will probably make its first appearance in 6.4.1.

fwiw, wxVdigit and wxNviz are currently disabled in the 6.4 stable branch and will also likely reappear for 6.4.1.

among other things, this means that debian/patches/swig.dpatch will need to be adjusted/removed in the DebianGIS svn when packaging the next release.

regards, Hamish

comment:5 Changed 9 years ago by cmbarton

wxNVIZ and wxDigitize worked fine for me in the svn version I compiled yesterday.

I thought these were only disabled for MS Windows. I also thought that swig stays in 6.4.0, but would be replaced by ctypes in 6.4.1. I'm assuming that this holds for Linux too.

I may be confused of course, but the new wx tools do work for Mac as of yesterday.

Michael

comment:6 in reply to:  5 Changed 9 years ago by hamish

Replying to cmbarton:

wxNVIZ and wxDigitize worked fine for me in the svn version I compiled yesterday.

which branch?

in 6.4svn they are now disabled in the gui/wxpython Makefile. installed copies from earlier builds might be lurking around still.

they work fine for me too, but the problem is if they die with an error they take down the rest of the gui with them, and if a user installs a packaged version of GRASS, and then upgrades their python or wx later, it all stops working (AFAIU). also the wxNviz in 6.4 is well behind Martin's work in the dev branches, so not an accurate representation & probable source of many already-fixed bug reports.

I thought these were only disabled for MS Windows.

nope, since a little while ago they are now changed to be disabled across the board. (in 6.4 only)

I also thought that swig stays in 6.4.0,

nope, it's now gone. if it's there people will expect it to stay and try to use it (and this was actually starting to happen too). better not to waste their time with what will be a dead-end effort.

but would be replaced by ctypes in 6.4.1.

yes.

I'm assuming that this holds for Linux too.

for all.

I may be confused of course, but the new wx tools do work for Mac as of yesterday.

ie wxVdigit and wxNviz in 6.4? expected. (I am confused by this last sentence and your first one in the post)

Hamish

comment:7 Changed 9 years ago by cmbarton

Sorry for the confusion. I assumed that this is all about 6.4.

I updated 6.4 from the svn yesterday. Did the normal make distclean and compiled. wxNVIZ and wxDigit both work fine for me.

Michael

comment:8 in reply to:  7 Changed 9 years ago by martinl

Replying to cmbarton:

Sorry for the confusion. I assumed that this is all about 6.4.

I updated 6.4 from the svn yesterday. Did the normal make distclean and compiled. wxNVIZ and wxDigit both work fine for me.

as Hamish noted wxNviz and wxVdigit are not built by default

ls dist.i686-pc-linux-gnu/etc/wxpython
compat  gis_set.py  gui_modules  icons  images  README  scripts  wxgui.py  xml

You need to compile gui/wxpython/vdigit|nviz manually to get them. Martin

comment:9 Changed 9 years ago by cmbarton

I just updated GRASS 6.4 from the svn, revision 37101, did a make distclean and compiled.

wxNVIZ and wxDigit work fine by default. I'm not complaining, but simply note that this is not turned off for the Mac.

I have not compiled these separately. I'm using the same configure string that I've been using for many months. I have swig installed, of course.

Michael

Note: See TracTickets for help on using tickets.