Opened 10 years ago

Closed 8 years ago

#757 closed task (wontfix)

WinGRASS: GUI window from cmd line

Reported by: silviap Owned by: grass-dev@…
Priority: trivial Milestone: 6.4.0
Component: wxGUI Version: 6.4.0 RCs
Keywords: wingrass Cc:
CPU: Unspecified Platform: MSWindows XP

Description

When starting GRASS with the MinGW shell it just gives the help in the shell, rather than opening the module's dialog.

Change History (12)

comment:1 Changed 10 years ago by martinl

Platform: UnspecifiedMSWindows 2K

Please specify at least the platform and GRASS version...

comment:2 Changed 10 years ago by silviap

Component: defaultwxGUI
Platform: MSWindows 2KMSWindows XP
Priority: normaltrivial
Type: defecttask
Version: unspecified6.4.0 RCs

comment:3 Changed 10 years ago by hamish

which icon did you start with? The blue "M" or the blue "M" with the GRASS logo in it or another?

which version of 6.4.0rc5 or svn r12345? Installed from the Osgeo4w installer or Colin's native binary?

If you type "g.gui" at the grass prompt and press return, what happens?

perhaps send a screenshot?

Hamish

comment:4 in reply to:  3 ; Changed 10 years ago by silviap

Replying to hamish:

which icon did you start with? The blue "M" or the blue "M" with the GRASS logo in it or another?

The blue M (MinGW shell)

which version of 6.4.0rc5 or svn r12345? Installed from the Osgeo4w installer or Colin's native binary?

native Stand-alone Installer package by Colin Nielsen

If you type "g.gui" at the grass prompt and press return, what happens?

perhaps send a screenshot?

Sorry, I don't have any windows right now..

silvia

comment:5 in reply to:  4 ; Changed 10 years ago by hamish

Replying to hamish:

which icon did you start with? The blue "M" or the blue "M" with the GRASS logo in it or another?

Replying to silviap:

The blue M (MinGW shell)

I don't have it running in front of me so I may be mistaken, but I think the one you want is the M with the grass white diamond logo half over the top of it, or the white diamond one by itself. I think the blue M alone is just the MSys UNIX shell ... not actually GRASS at all. :)

try this one: source:grass/trunk/mswindows/Installer-Files/GRASS_MSys.ico

or try this one: source:grass/trunk/mswindows/Installer-Files/GRASS.ico

but not this: source:grass/trunk/mswindows/Installer-Files/MSYS_Custom_Icon.ico

Hamish

comment:6 in reply to:  5 Changed 10 years ago by silviap

Replying to hamish:

Replying to hamish:

which icon did you start with? The blue "M" or the blue "M" with the GRASS logo in it or another?

Replying to silviap:

The blue M (MinGW shell)

I don't have it running in front of me so I may be mistaken, but I think the one you want is the M with the grass white diamond logo half over the top of it, or the white diamond one by itself. I think the blue M alone is just the MSys UNIX shell ... not actually GRASS at all. :)

I don't have it running in front of me as well... so it was the M with the grass logo, not just the MSys icon - the grass shell and not just the MSys Unix shell. Colin agrees that it just gives the help in the shell, rather than opening the module's dialog. So I just opened a ticket.

try this one: source:grass/trunk/mswindows/Installer-Files/GRASS_MSys.ico

or try this one: source:grass/trunk/mswindows/Installer-Files/GRASS.ico

but not this: source:grass/trunk/mswindows/Installer-Files/MSYS_Custom_Icon.ico

Hamish

comment:7 Changed 10 years ago by cnielsen

A bit of misunderstanding here. GRASS is starting fine, but once open the dialogs of individual modules aren't opening when they are typed into the shell. Instead if you type r.walk or whatever, the module's ascii help text is output to the shell (as required arguments are missing, ie. output) instead of opening a dialog window where the arguments may be entered.

-Colin

comment:8 in reply to:  7 ; Changed 10 years ago by silviap

Replying to cnielsen:

A bit of misunderstanding here. GRASS is starting fine, but once open the dialogs of individual modules aren't opening when they are typed into the shell. Instead if you type r.walk or whatever, the module's ascii help text is output to the shell (as required arguments are missing, ie. output) instead of opening a dialog window where the arguments may be entered.

-Colin

GRASS is starting fine, thank you for explaining it better and sorry for creating the misunderstanding.

comment:9 in reply to:  7 Changed 10 years ago by glynn

Replying to cnielsen:

A bit of misunderstanding here. GRASS is starting fine, but once open the dialogs of individual modules aren't opening when they are typed into the shell. Instead if you type r.walk or whatever, the module's ascii help text is output to the shell (as required arguments are missing, ie. output) instead of opening a dialog window where the arguments may be entered.

When you run the command without arguments, the GUI interface is only generated if stdin is a terminal, according to isatty().

On Windows, isatty() only recognises the standard Windows Command Prompt as a terminal. The MSys terminal (rxvt) isn't considered a terminal by isatty() (AFAICT, any child processes will have their standard descriptors connected to pipes).

I'm not sure that there is anything which can be done about this, other than skipping the isatty() check altogether on Windows (although that may be an acceptable solution; I don't know of a reason why the check is actually necessary).

You can still force a GUI using the --ui switch.

comment:10 Changed 9 years ago by hellik

Keywords: wingrass added

comment:11 in reply to:  8 Changed 9 years ago by hellik

Replying to silviap:

Replying to cnielsen:

A bit of misunderstanding here. GRASS is starting fine, but once open the dialogs of individual modules aren't opening when they are typed into the shell. Instead if you type r.walk or whatever, the module's ascii help text is output to the shell (as required arguments are missing, ie. output) instead of opening a dialog window where the arguments may be entered.

-Colin

GRASS is starting fine, thank you for explaining it better and sorry for creating the misunderstanding.

closing the ticket?

comment:12 Changed 8 years ago by hamish

Resolution: wontfix
Status: newclosed

Glynn wrote:

When you run the command without arguments, the GUI interface is only generated if stdin is a terminal, according to isatty().

On Windows, isatty() only recognises the standard Windows Command Prompt as a terminal. The MSys terminal (rxvt) isn't considered a terminal by isatty()

...

You can still force a GUI using the --ui switch.

the problem is well understood; I just tested and the --ui work-around still works; closing the ticket with the nearest reason to "cantfix".

Hamish

Note: See TracTickets for help on using tickets.